ar71xx: change generated Buffalo firmware versions
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 21:34:32 +0000 (21:34 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 21:34:32 +0000 (21:34 +0000)
With version 1.76 the upgrade may fail with newer Buffalo firmwares with
a message like this:
"You can not update the firmware because the firmware version is earlier
than 1.82. Please use 1.82 or later version for firmware update."

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28815 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index d687f6f..dbb8c17 100644 (file)
@@ -134,10 +134,10 @@ define Image/Build/WZRHPG30XNH
                        echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
                        dd if=$(call sysupname,$(1),$(2)); \
                ) > $(call imgname,$(1),$(2))-tftp.bin; \
-               buffalo-enc -p $(4) -v 1.76 \
+               buffalo-enc -p $(4) -v 1.99 \
                        -i $(call sysupname,$(1),$(2)) \
                        -o $(KDIR)/$(2).enc; \
-               buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \
+               buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
                        -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
                        -i $(KDIR)/$(2).enc \
                        -o $(call factoryname,$(1),$(2)); \
@@ -152,10 +152,10 @@ define Image/Build/WHRHPG300N
                        echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
                        dd if=$(call sysupname,$(1),$(2)); \
                ) > $(call imgname,$(1),$(2))-tftp.bin; \
-               buffalo-enc -p $(5) -v 1.76 \
+               buffalo-enc -p $(5) -v 1.99 \
                        -i $(call sysupname,$(1),$(2)) \
                        -o $(KDIR)/$(2).enc; \
-               buffalo-tag -b $(5) -p $(5) -a ath -v 1.76 -m 1.01 -l mlang8 \
+               buffalo-tag -b $(5) -p $(5) -a ath -v 1.99 -m 1.01 -l mlang8 \
                        -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
                        -i $(KDIR)/$(2).enc \
                        -o $(call factoryname,$(1),$(2)); \