[tools] bison: make yacc wrapper relocatable
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jan 2012 17:30:38 +0000 (17:30 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Jan 2012 17:30:38 +0000 (17:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29831 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/bison/patches/000-relocatable.patch [new file with mode: 0644]

diff --git a/tools/bison/patches/000-relocatable.patch b/tools/bison/patches/000-relocatable.patch
new file mode 100644 (file)
index 0000000..f83bb1e
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -77,6 +77,7 @@ MOSTLYCLEANFILES = yacc
+ yacc:
+       echo '#! /bin/sh' >$@
++      echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+       echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+       chmod a+x $@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1352,6 +1352,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+ yacc:
+       echo '#! /bin/sh' >$@
++      echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+       echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+       chmod a+x $@