at91: fix at91-adc dependencies
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Oct 2014 19:45:31 +0000 (19:45 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Oct 2014 19:45:31 +0000 (19:45 +0000)
Error reported by buildbot:
Package kmod-at91-adc is missing dependencies for the following libraries:
input-core.ko

only compile tested

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42893 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/at91/modules.mk

index 4678b92..7f98233 100644 (file)
@@ -38,7 +38,7 @@ $(eval $(call KernelPackage,pwm-atmel))
 define KernelPackage/at91-adc
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ADC on atmel SoC
-  DEPENDS:=@TARGET_at91 +kmod-iio-core
+  DEPENDS:=@TARGET_at91 +kmod-iio-core +kmod-input-core
   KCONFIG:=CONFIG_AT91_ADC
   FILES:=$(LINUX_DIR)/drivers/iio/adc/at91_adc.ko
   AUTOLOAD:=$(call AutoLoad,40,at91_adc)