PKG_CHECK_FORMAT_SECURITY: add a menuconfig option, disable by default
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 06:36:06 +0000 (06:36 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 06:36:06 +0000 (06:36 +0000)
The idea is still to enable it by default at some point
I've tested all ar71xx packages (except oldpackages) using CONFIG_ALL=y
Failing packages have been marked with PKG_CHECK_FORMAT_SECURITY:=0 for now
I can test more targets but i have no idea which are the most used

Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42282 3c298f89-4303-0410-b956-a3cf2f4a3e73

config/Config-build.in
include/package.mk

index 371ae76..02fe136 100644 (file)
@@ -93,6 +93,15 @@ menu "Global build settings"
 
                  If you are unsure, select N.
 
+       config PKG_CHECK_FORMAT_SECURITY
+               bool
+               prompt "Enable gcc format-security"
+               default n
+               help
+                 Add -Wformat -Werror=format-security to the CFLAGS
+                 You can disable this per package by adding
+                 PKG_CHECK_FORMAT_SECURITY:=0 in the package Makefile
+
        config PKG_BUILD_USE_JOBSERVER
                bool
                prompt "Use top-level make jobserver for packages"
index 88ec3ef..1cdab6b 100644 (file)
@@ -14,7 +14,7 @@ PKG_INSTALL_DIR ?= $(PKG_BUILD_DIR)/ipkg-install
 PKG_MD5SUM ?= unknown
 PKG_BUILD_PARALLEL ?=
 PKG_USE_MIPS16 ?= 1
-PKG_CHECK_FORMAT_SECURITY ?= 0
+PKG_CHECK_FORMAT_SECURITY ?= 1
 
 ifneq ($(CONFIG_PKG_BUILD_USE_JOBSERVER),)
   MAKE_J:=$(if $(MAKE_JOBSERVER),$(MAKE_JOBSERVER) -j)
@@ -34,8 +34,10 @@ ifdef CONFIG_USE_MIPS16
     TARGET_CFLAGS += -mips16 -minterlink-mips16
   endif
 endif
-ifeq ($(strip $(PKG_CHECK_FORMAT_SECURITY)),1)
-  TARGET_CFLAGS += -Wformat -Werror=format-security
+ifdef CONFIG_PKG_CHECK_FORMAT_SECURITY
+  ifeq ($(strip $(PKG_CHECK_FORMAT_SECURITY)),1)
+    TARGET_CFLAGS += -Wformat -Werror=format-security
+  endif
 endif
 
 include $(INCLUDE_DIR)/prereq.mk