6rd: honor tunlink in host dependency
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Feb 2015 07:42:12 +0000 (07:42 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Feb 2015 07:42:12 +0000 (07:42 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44541 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6rd/Makefile
package/network/ipv6/6rd/files/6rd.sh

index 82195c8..d3e4bf6 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=7
+PKG_VERSION:=8
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
@@ -19,7 +19,7 @@ define Package/6rd
   CATEGORY:=Network
   DEPENDS:=+kmod-ipv6 +kmod-sit
   TITLE:=6rd configuration support
-  MAINTAINER:=Stéphan Kochen <stephan@kochen.nl>
+  MAINTAINER:=Steven Barth <cyrus@openwrt.org>
   PKGARCH:=all
 endef
 
index 042d985..287f569 100644 (file)
@@ -23,7 +23,7 @@ proto_6rd_setup() {
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+       ( proto_add_host_dependency "$cfg" 0.0.0.0 "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"