zynq: Add Zybo device support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:44:29 +0000 (11:44 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:44:29 +0000 (11:44 +0000)
Signed-off-by: Jason Wu <jason.wu.misc@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49257 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-zynq/Makefile
target/linux/zynq/base-files/etc/board.d/02_network
target/linux/zynq/image/Makefile
target/linux/zynq/profiles/zybo.mk [new file with mode: 0644]

index 2053e8d..412415b 100644 (file)
@@ -41,9 +41,14 @@ define uboot/zed
        TITLE:=U-Boot $(PKG_VERSION) for Avnet Digilent ZedBoard Dev Board
 endef
 
+define uboot/zybo
+       TITLE:=U-Boot $(PKG_VERSION) for Digilent Zybo Dev Board
+endef
+
 UBOOTS := \
        zc702 \
        zed \
+       zybo \
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
index 35667c0..9659673 100755 (executable)
@@ -6,7 +6,7 @@
 board_config_update
 
 case "$(cat /tmp/sysinfo/board_name)" in
-       xlnx,zynq-zc702|xlnx,zynq-zed)
+       xlnx,zynq-zc702|xlnx,zynq-zed|xlnx,zynq-zybo)
                ucidef_set_interface_lan 'eth0'
                ;;
 esac
index 87975be..d803c33 100644 (file)
@@ -74,6 +74,10 @@ define Device/ZED
        $(call Device/DefaultConfig,zed)
 endef
 
+define Device/ZYBO
+       $(call Device/DefaultConfig,zybo)
+endef
+
 define Image/BuildKernel
        $(eval $(call Device/$(PROFILE)))
        $(call Image/boot-imgs)
diff --git a/target/linux/zynq/profiles/zybo.mk b/target/linux/zynq/profiles/zybo.mk
new file mode 100644 (file)
index 0000000..dfe7e67
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZYBO
+       NAME:=ZYBO development baord
+endef
+
+define Profile/ZYBO/Description
+       Build firmware image for Digilent ZYBO development board.
+endef
+
+$(eval $(call Profile,ZYBO))