brcm63xx: make use of the new BuildDTB command
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Jul 2015 11:13:47 +0000 (11:13 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Jul 2015 11:13:47 +0000 (11:13 +0000)
Now that we have a BuildDTB command, make use of it instead of calling
dtc directly.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46390 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/image/Makefile

index 63cd90a..98d1452 100755 (executable)
@@ -198,7 +198,7 @@ endef
 
 define Image/PrepareCFELzmaKernelDTB
        # compile the dts (the dtb will be later reused for the lzma loader)
-       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
+       $(call Image/BuildDTB,../dts/$(1).dts,$(DTS_DIR)/$(1).dtb)
        cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
        $(call Image/PrepareCFELzmaKernel,-$(1))
        rm -f $(KDIR)/vmlinux-$(1)