ar71xx: use the lzma loader for the WRT160NL
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Sep 2013 11:40:45 +0000 (11:40 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Sep 2013 11:40:45 +0000 (11:40 +0000)
Partition layout before:
  0x000000040000-0x0000001a0000 : "kernel"
  0x0000001a0000-0x0000007e0000 : "rootfs"
  mtd: partition "rootfs" set to be root filesystem
  mtd: partition "rootfs_data" created automatically, ofs=0x350000, len=0x490000
  0x000000350000-0x0000007e0000 : "rootfs_data"

after:
  0x000000040000-0x000000140000 : "kernel"
  0x000000140000-0x0000007e0000 : "rootfs"
  mtd: partition "rootfs" set to be root filesystem
  mtd: partition "rootfs_data" created automatically, ofs=0x2f0000, len=0x4f0000
  0x0000002f0000-0x0000007e0000 : "rootfs_data"

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37915 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index ac9c8b8..98f364d 100644 (file)
@@ -618,8 +618,8 @@ define Image/Build/TPLINK-LZMA/initramfs
                -o $(call imgname,$(1),$(2))-uImage.bin
 endef
 
-
-Image/Build/CyberTAN/buildkernel=$(call MkuImageGzip,$(2),$(3))
+Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
+Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
 
 define Image/Build/CyberTAN
        $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \