kernel: fix kmod-crypto-hw-ppc4xx dependencies
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jul 2013 08:20:01 +0000 (08:20 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Jul 2013 08:20:01 +0000 (08:20 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37488 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index 6a636fc..4f9517f 100644 (file)
@@ -184,7 +184,7 @@ define KernelPackage/crypto-hw-ppc4xx
        CONFIG_CRYPTO_DEV_PPC4XX
   FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
   AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
-  $(call AddDepends/crypto)
+  $(call AddDepends/crypto,+kmod-crypto-manager +kmod-crypto-hash)
 endef
 
 define KernelPackage/crypto-hw-ppc4xx/description