Add sipsak package
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 May 2005 20:57:05 +0000 (20:57 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 May 2005 20:57:05 +0000 (20:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@898 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/sipsak/Config.in [new file with mode: 0644]
package/sipsak/Makefile [new file with mode: 0644]
package/sipsak/ipkg/sipsak.control [new file with mode: 0644]

index f42ceed..7cc6c6e 100644 (file)
@@ -63,6 +63,7 @@ source "package/maradns/Config.in"
 source "package/ttcp/Config.in"
 source "package/robocfg/Config.in"
 source "package/siproxd/Config.in"
+source "package/sipsak/Config.in"
 
 comment "Libraries"
 source "package/libpthread/Config.in"
index 0df4d17..b92938b 100644 (file)
@@ -85,6 +85,7 @@ package-$(BR2_PACKAGE_LIBSASL2) += cyrus-sasl
 package-$(BR2_PACKAGE_LIBLTDL) += libtool
 package-$(BR2_PACKAGE_LIBOSIP2) += libosip2
 package-$(BR2_PACKAGE_SIPROXD) += siproxd
+package-$(BR2_PACKAGE_SIPSAK) += sipsak
 
 DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd
 DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
@@ -131,6 +132,7 @@ fprobe-compile: libpcap-compile
 cyrus-sasl-compile: openssl-compile
 openldap-compile: cyrus-sasl-compile openssl-compile
 siproxd-compile: libosip2-compile
+sipsak-compile: openssl-compile
 
 snort-compile: libnet-compile libpcap-compile pcre-compile
 ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
diff --git a/package/sipsak/Config.in b/package/sipsak/Config.in
new file mode 100644 (file)
index 0000000..1ad11d0
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_SIPSAK
+       tristate "sipsak - a SIP (Session Initiation Protocol) stress and diagnostics utility"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_OPENSSL
+       help
+         A SIP (Session Initiation Protocol) stress and diagnostics utility
+         
+         http://www.sipsak.org/
+         
+         Depends: openssl
+         
diff --git a/package/sipsak/Makefile b/package/sipsak/Makefile
new file mode 100644 (file)
index 0000000..5adfc6a
--- /dev/null
@@ -0,0 +1,65 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sipsak
+PKG_VERSION:=0.8.12
+PKG_RELEASE:=1
+PKG_MD5SUM:=9740451fd72b5c7e6d85aa516ba5c19c
+
+PKG_SOURCE_URL:=http://download.berlios.de/sipsak/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SIPSAK,sipsak,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ac_cv_func_malloc_0_nonnull=yes \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --disable-static \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_SIPSAK):
+       install -d -m0755 $(IDIR_SIPSAK)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/sipsak $(IDIR_SIPSAK)/usr/bin/
+       $(RSTRIP) $(IDIR_SIPSAK)
+       $(IPKG_BUILD) $(IDIR_SIPSAK) $(PACKAGE_DIR)
diff --git a/package/sipsak/ipkg/sipsak.control b/package/sipsak/ipkg/sipsak.control
new file mode 100644 (file)
index 0000000..328e10c
--- /dev/null
@@ -0,0 +1,9 @@
+Package: sipsak
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/sipsak/
+Description: a SIP (Session Initiation Protocol) stress and diagnostics utility
+Depends: libopenssl