[include] host-build.mk: define a variable HOST_STATIC_LINKING which is set to "...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Aug 2012 12:34:25 +0000 (12:34 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Aug 2012 12:34:25 +0000 (12:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33138 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index 6fc29b3..a8bc79e 100644 (file)
@@ -65,6 +65,10 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_CONFIGURE_CMD = ./configure
 
+ifneq ($(HOST_OS),Darwin)
+  HOST_STATIC_LINKING = -static
+endif
+
 define Host/Configure/Default
        (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \