toolchain/gcc: pass proper flags for arm hard float build
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jul 2014 20:28:53 +0000 (20:28 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jul 2014 20:28:53 +0000 (20:28 +0000)
This fixes eglibc build failure. More information about the bug can be found on
the link below.

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61796

Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41657 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk

index 5dfbc48..e8ca778 100644 (file)
@@ -162,6 +162,13 @@ ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif
 
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif
 
+ifneq ($(CONFIG_SOFT_FLOAT),y)
+  ifeq ($(CONFIG_arm),y)
+    GCC_CONFIGURE+= \
+               --with-float=hard
+  endif
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \