Use find -exec instead of xargs
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2007 16:09:15 +0000 (16:09 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2007 16:09:15 +0000 (16:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6837 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/image.mk
include/package-ipkg.mk
scripts/feeds.sh
target/imagebuilder/Makefile
target/sdk/Makefile

index bee47c4..ab4c4d5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -171,7 +171,7 @@ docclean:
        $(MAKE) -C docs/ clean
 
 symlinkclean:
-       find package -type l | xargs rm -f
+       find package -type l -exec rm -f {} \;
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world
 FORCE: ;
index 78e1a2f..eb59ea6 100644 (file)
@@ -79,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
+       find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
+       find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef
index 8d6f195..d824d26 100644 (file)
@@ -71,9 +71,9 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | xargs rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | xargs rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | xargs rm -f
+       -find $$(IDIR_$(1)) -name CVS   -exec rm -rf {} \;
+       -find $$(IDIR_$(1)) -name .svn  -exec rm -rf {} \;
+       -find $$(IDIR_$(1)) -name '.#*' -exec rm -f  {} \;
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false 
index 351c87c..d2dfe9d 100755 (executable)
@@ -22,7 +22,7 @@ cd $TOPDIR
 
 # Some functions we might call several times a run
 delete_symlinks() {
-       find $1 -type l | xargs rm -f
+       find $1 -type l -exec rm -f {} \;
 }
 
 setup_symlinks() {
index 0cbbfa2..3d830bb 100644 (file)
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        $(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
        rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
        -cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
-       find $(IB_BUILD_DIR) -name .svn | xargs rm -rf 
-       find $(IB_BUILD_DIR) -name CVS | xargs rm -rf 
+       find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} \;
+       find $(IB_BUILD_DIR) -name CVS -exec rm -rf  {} \;
        (cd $(BUILD_DIR); \
                tar cfj $@ $(IB_NAME); \
        )
index d65b934..3cae4b3 100644 (file)
@@ -35,8 +35,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
        $(CP) ./files/package/rules.mk $(SDK_BUILD_DIR)/package/
        echo OPENWRTVERSION:=$(OPENWRTVERSION) > $(SDK_BUILD_DIR)/.version.mk
        rm -rf $(SDK_BUILD_DIR)/staging_dir*/ccache
-       find $(SDK_BUILD_DIR) -name .svn | xargs rm -rf 
-       find $(SDK_BUILD_DIR) -name CVS | xargs rm -rf 
+       find $(SDK_BUILD_DIR) -name .svn -exec rm -rf {} \;
+       find $(SDK_BUILD_DIR) -name CVS -exec rm -rf  {} \;
        (cd $(BUILD_DIR); \
                tar cfj $@ $(SDK_NAME); \
        )