bcm53xx: this ARM SoC does not have a FPU, use soft float.
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Nov 2013 22:26:08 +0000 (22:26 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Nov 2013 22:26:08 +0000 (22:26 +0000)
model name      : ARMv7 Processor rev 0 (v7l)
Features        : swp half thumb fastmult edsp tls

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38796 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
target/linux/bcm53xx/Makefile

index e00fcef..467ef35 100644 (file)
@@ -230,6 +230,7 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
     CPU_CFLAGS_vfp = -mfpu=vfp -mfloat-abi=softfp
     CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16 -mfloat-abi=softfp
+    CPU_CFLAGS_soft = -mfloat-abi=softfp
   endif
   ifeq ($(ARCH),powerpc)
     CPU_CFLAGS_603e:=-mcpu=603e
index 69ca530..e13876e 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfp
+CPU_SUBTYPE:=soft
 
 LINUX_VERSION:=3.10.18