brcm63xx: Add DT support for A4001N
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 11:28:43 +0000 (11:28 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 11:28:43 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42245 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/dts/a4001n.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/adb.mk

diff --git a/target/linux/brcm63xx/dts/a4001n.dts b/target/linux/brcm63xx/dts/a4001n.dts
new file mode 100644 (file)
index 0000000..011fbf4
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "ADB P.DG A4001N";
+       compatible = "adb,a4001n", "brcm,bcm6328";
+};
index 31dd399..009c34e 100755 (executable)
@@ -243,8 +243,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
        $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
 
-       # ADB P.DG A4001N
-       $(call Image/Build/CFE,$(1),96328dg2x2,6328,A4001N,,--pad 4)
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
        # BT Voyager V210_ROI, V210_WB
@@ -343,6 +341,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-4M-fla
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-flash-generic,,--pad 4))
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-flash-generic,,--pad 8))
 
+# ADB P.DG A4001N
+$(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
 # ADB P.DG A4001N1
 $(eval $(call CfeImageDTB,A4001N1,a4001n1,963281T_TEF,6328,A4001N1,,--pad 8))
 # Asmax AR 1004g
index ee5cf9a..ed5aa03 100644 (file)
@@ -1,11 +1,12 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -609,6 +609,95 @@ static struct board_info __initdata boar
+@@ -609,6 +609,96 @@ static struct board_info __initdata boar
        },
  };
  
 +static struct board_info __initdata board_A4001N = {
 +      .name                           = "96328dg2x2",
++      .of_board_id                    = "adb,a4001n",
 +      .expected_cpu_id                = 0x6328,
 +
 +      .has_uart0                      = 1,
@@ -95,8 +96,8 @@
 +
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
-       .of_board_id                    = "comtrend,wap-5813n",
-@@ -4957,6 +5046,7 @@ static const struct board_info __initcon
+       .of_board_id                    = "adb,a4001n1",
+@@ -4957,6 +5047,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 80fe15c..6cc28ea 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5040,6 +5175,7 @@ static const struct board_info __initcon
+@@ -5041,6 +5176,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 864224c..13c7524 100644 (file)
@@ -5,6 +5,16 @@
 # See /LICENSE for more information.
 #
 
+define Profile/A4001N
+  NAME:=ADB P.DG A4001N
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/A4001N/Description
+  Package set optimized for A4001N.
+endef
+$(eval $(call Profile,A4001N))
+
 define Profile/A4001N1
   NAME:=ADB P.DG A4001N1
   PACKAGES:=kmod-b43 wpad-mini \