kernel: update linux 3.7 to 3.7.4
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jan 2013 17:08:37 +0000 (17:08 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Jan 2013 17:08:37 +0000 (17:08 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35318 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/cns21xx/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.7/101-rt288x_serial_driver_hack.patch
target/linux/rb532/Makefile
target/linux/x86/geos/target.mk

index 932f186..f3d8aed 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.3)
-  LINUX_KERNEL_MD5SUM:=6b35fb08d229d4c6d246f27c7d475790
+ifeq ($(LINUX_VERSION),3.7.4)
+  LINUX_KERNEL_MD5SUM:=b34c31c954bebdfb568244dd3897e7c6
 endif
 
 # disable the md5sum check for unknown kernel versions
 endif
 
 # disable the md5sum check for unknown kernel versions
index 462de16..bf8fc98 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 2a197ed..a5412b5 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c13a1cb..7e56e91 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 74ba4f0..eb07e39 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index da05f10..78ba3e4 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 DEVICE_TYPE:=developerboard
 
 
 DEVICE_TYPE:=developerboard
 
index 5670439..22223eb 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 36c10b3..675681f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 9abd715..83fb0c3 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 82d20b6..346eca6 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 8bc3327..4269e86 100644 (file)
@@ -28,7 +28,7 @@
  
 --- a/drivers/tty/serial/8250/8250.c
 +++ b/drivers/tty/serial/8250/8250.c
  
 --- a/drivers/tty/serial/8250/8250.c
 +++ b/drivers/tty/serial/8250/8250.c
-@@ -308,9 +308,9 @@ static void default_serial_dl_write(stru
+@@ -314,9 +314,9 @@ static void default_serial_dl_write(stru
        serial_out(up, UART_DLM, value >> 8 & 0xff);
  }
  
        serial_out(up, UART_DLM, value >> 8 & 0xff);
  }
  
@@ -40,7 +40,7 @@
  static const u8 au_io_in_map[] = {
        [UART_RX]  = 0,
        [UART_IER] = 2,
  static const u8 au_io_in_map[] = {
        [UART_RX]  = 0,
        [UART_IER] = 2,
-@@ -489,7 +489,7 @@ static void set_io_from_upio(struct uart
+@@ -495,7 +495,7 @@ static void set_io_from_upio(struct uart
                break;
  #endif
  
                break;
  #endif
  
@@ -49,7 +49,7 @@
        case UPIO_AU:
                p->serial_in = au_serial_in;
                p->serial_out = au_serial_out;
        case UPIO_AU:
                p->serial_in = au_serial_in;
                p->serial_out = au_serial_out;
-@@ -701,22 +701,19 @@ static int size_fifo(struct uart_8250_po
+@@ -707,22 +707,19 @@ static int size_fifo(struct uart_8250_po
   */
  static unsigned int autoconfig_read_divisor_id(struct uart_8250_port *p)
  {
   */
  static unsigned int autoconfig_read_divisor_id(struct uart_8250_port *p)
  {
@@ -78,7 +78,7 @@
        serial_out(p, UART_LCR, old_lcr);
  
        return id;
        serial_out(p, UART_LCR, old_lcr);
  
        return id;
-@@ -842,7 +839,7 @@ static int broken_efr(struct uart_8250_p
+@@ -848,7 +845,7 @@ static int broken_efr(struct uart_8250_p
        /*
         * Exar ST16C2550 "A2" devices incorrectly detect as
         * having an EFR, and report an ID of 0x0201.  See
        /*
         * Exar ST16C2550 "A2" devices incorrectly detect as
         * having an EFR, and report an ID of 0x0201.  See
index a4f195a..ab032e3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 53cef2a..a45c07f 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \