build: add a prereq check for file (#15692)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Apr 2014 19:28:11 +0000 (19:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Apr 2014 19:28:11 +0000 (19:28 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40568 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index b7ada69..2e8d712 100644 (file)
@@ -187,3 +187,7 @@ endef
 $(eval $(call Require,getopt-extended, \
        Please install an extended getopt version that supports --long \
 ))
+
+$(eval $(call RequireCommand,file, \
+       Please install file. \
+))