[cobalt] package cobalt lcd as a module
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2012 14:01:46 +0000 (14:01 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2012 14:01:46 +0000 (14:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32840 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/cobalt/config-3.3
target/linux/cobalt/modules.mk [new file with mode: 0644]

index c29540e..ccc5839 100644 (file)
@@ -45,13 +45,6 @@ CONFIG_DUMMY_CONSOLE=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_ELF_CORE=y
 CONFIG_ENABLE_MUST_CHECK=y
-CONFIG_FB=y
-CONFIG_FB_COBALT=y
-# CONFIG_FB_SM7XX is not set
-# CONFIG_FB_WMT_GE_ROPS is not set
-# CONFIG_FB_XGI is not set
-# CONFIG_FIRMWARE_EDID is not set
-CONFIG_FIRMWARE_IN_KERNEL=y
 CONFIG_FS_POSIX_ACL=y
 CONFIG_GENERIC_ACL=y
 CONFIG_GENERIC_CLOCKEVENTS=y
diff --git a/target/linux/cobalt/modules.mk b/target/linux/cobalt/modules.mk
new file mode 100644 (file)
index 0000000..fcba757
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/fb-cobalt
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Cobalt framebuffer support
+  DEPENDS:=@TARGET_cobalt +kmod-fb
+  KCONFIG:=CONFIG_FB_COBALT
+  FILES:=$(LINUX_DIR)/drivers/video/cobalt_lcdfb.ko
+  AUTOLOAD:=$(call AutoLoad,50,cobalt_lcdfb)
+endef
+
+define KernelPackage/fb-cobalt/descriptione
+  Kernel module for the Cobalt Microservers framebuffer
+endef
+
+$(eval $(call KernelPackage,fb-cobalt))