package/valgrind: fix build on eglibc
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Feb 2015 13:53:51 +0000 (13:53 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Feb 2015 13:53:51 +0000 (13:53 +0000)
configure tries to guess pagesize by calling getconf, provided by eglibc and compiled for the target, not the host.

Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44445 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/valgrind/Makefile

index e2c7f67..354e3c4 100644 (file)
@@ -101,7 +101,8 @@ CONFIGURE_ARGS += \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin