kernel: update linux 3.7 to 3.7.5
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jan 2013 18:29:45 +0000 (18:29 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jan 2013 18:29:45 +0000 (18:29 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35390 3c298f89-4303-0410-b956-a3cf2f4a3e73

33 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.7/169-MIPS-ath79-allow-to-specify-bus-number-in-PCI-IRQ-ma.patch
target/linux/ar71xx/patches-3.7/170-MIPS-ath79-add-PCI-controller-registration-code-for-.patch
target/linux/ar71xx/patches-3.7/203-spi-ath79-use-gpio_request_one.patch
target/linux/ar71xx/patches-3.7/204-spi-ath79-avoid-multiple-initialization-of-the-SPI-c.patch
target/linux/ar71xx/patches-3.7/206-spi-ath79-make-chipselect-logic-more-flexible.patch
target/linux/ar71xx/patches-3.7/212-MIPS-ath79-fix-GPIO-function-selection-for-AR934x-So.patch
target/linux/ar71xx/patches-3.7/406-mtd-m25p80-allow-to-specify-max-read-size.patch
target/linux/ar71xx/patches-3.7/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
target/linux/ar71xx/patches-3.7/412-mtd-m25p80-zero-partition-parser-data.patch
target/linux/ar71xx/patches-3.7/505-MIPS-ath79-add-ath79_gpio_function_select.patch
target/linux/ar71xx/patches-3.7/521-MIPS-ath79-enable-UART-for-early_serial.patch
target/linux/ar71xx/patches-3.7/606-MIPS-ath79-pb44-fixes.patch
target/linux/ar71xx/patches-3.7/902-unaligned_access_hacks.patch
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/010-mtd_mp25p80_add_gd25q32_gd25q64.patch
target/linux/generic/patches-3.7/340-module_alloc_size_check.patch
target/linux/generic/patches-3.7/470-mtd_m25p80_add_pm25lv_flash_support.patch
target/linux/generic/patches-3.7/473-mtd_m25p80_add_w25q128.patch
target/linux/generic/patches-3.7/476-mtd-m25p80-allow-to-disable-small-sector-erase.patch
target/linux/generic/patches-3.7/920-unable_to_open_console.patch
target/linux/generic/patches-3.7/950-vm_exports.patch
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.7/0301-gptu.patch
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/geos/target.mk

index f3d8aed..d5feae3 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.4)
-  LINUX_KERNEL_MD5SUM:=b34c31c954bebdfb568244dd3897e7c6
+ifeq ($(LINUX_VERSION),3.7.5)
+  LINUX_KERNEL_MD5SUM:=ae355001775bc841132fe0fea2f354d4
 endif
 
 # disable the md5sum check for unknown kernel versions
index bf8fc98..fe919da 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index a5412b5..315db0e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 89ab5ac..bd95d71 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/ath79/pci.c
 +++ b/arch/mips/ath79/pci.c
-@@ -75,7 +75,9 @@ int __init pcibios_map_irq(const struct 
+@@ -75,7 +75,9 @@ int __init pcibios_map_irq(const struct
                const struct ath79_pci_irq *entry;
  
                entry = &ath79_pci_irq_map[i];
index 5c6388c..0c3889f 100644 (file)
@@ -44,7 +44,7 @@ Subject: [PATCH 26/34] MIPS: ath79: add PCI controller registration code for the
  int __init pcibios_map_irq(const struct pci_dev *dev, uint8_t slot, uint8_t pin)
  {
        int irq = -1;
-@@ -64,6 +79,9 @@ int __init pcibios_map_irq(const struct 
+@@ -64,6 +79,9 @@ int __init pcibios_map_irq(const struct
                           soc_is_ar9344()) {
                        ath79_pci_irq_map = ar724x_pci_irq_map;
                        ath79_pci_nr_irqs = ARRAY_SIZE(ar724x_pci_irq_map);
index a7329b2..12559bc 100644 (file)
@@ -32,18 +32,19 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 -              status = gpio_request(cdata->gpio, dev_name(&spi->dev));
 -              if (status)
 -                      return status;
-+              flags = GPIOF_DIR_OUT;
-+              if (spi->mode & SPI_CS_HIGH)
-+                      flags |= GPIOF_INIT_HIGH;
-+              else
-+                      flags |= GPIOF_INIT_LOW;
+-
 -              status = gpio_direction_output(cdata->gpio,
 -                                             spi->mode & SPI_CS_HIGH);
 -              if (status) {
 -                      gpio_free(cdata->gpio);
 -                      return status;
 -              }
++              flags = GPIOF_DIR_OUT;
++              if (spi->mode & SPI_CS_HIGH)
++                      flags |= GPIOF_INIT_HIGH;
++              else
++                      flags |= GPIOF_INIT_LOW;
++
 +              status = gpio_request_one(cdata->gpio, flags,
 +                                        dev_name(&spi->dev));
        }
index 976159c..c6f4b2b 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/drivers/spi/spi-ath79.c
 +++ b/drivers/spi/spi-ath79.c
-@@ -96,16 +96,8 @@ static void ath79_spi_chipselect(struct 
+@@ -96,16 +96,8 @@ static void ath79_spi_chipselect(struct
  
  }
  
index da83e2e..34df175 100644 (file)
@@ -170,7 +170,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  struct ath79_spi {
        struct spi_bitbang      bitbang;
        u32                     ioc_base;
-@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct 
+@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
  {
        struct ath79_spi *sp = ath79_spidev_to_sp(spi);
        int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
@@ -178,7 +178,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
        if (is_active) {
                /* set initial clock polarity */
-@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct 
+@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
                ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
        }
  
index 3e41789..a9845ba 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/ath79/gpio.c
 +++ b/arch/mips/ath79/gpio.c
-@@ -137,47 +137,61 @@ static struct gpio_chip ath79_gpio_chip 
+@@ -137,47 +137,61 @@ static struct gpio_chip ath79_gpio_chip
        .base                   = 0,
  };
  
index b80a32a..30d4fcd 100644 (file)
@@ -84,7 +84,7 @@
  
        mutex_unlock(&flash->lock);
  
-@@ -910,6 +936,12 @@ static int __devinit m25p_probe(struct s
+@@ -914,6 +940,12 @@ static int __devinit m25p_probe(struct s
        flash->mtd._erase = m25p80_erase;
        flash->mtd._read = m25p80_read;
  
index 707b49d..7f35b23 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -1003,7 +1003,9 @@ static int __devinit m25p_probe(struct s
+@@ -1007,7 +1007,9 @@ static int __devinit m25p_probe(struct s
        /* partitions should match sector boundaries; and it may be good to
         * use readonly partitions for writeprotected sectors (BP2..BP0).
         */
index a3c7ebc..7d49362 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -963,6 +963,7 @@ static int __devinit m25p_probe(struct s
+@@ -967,6 +967,7 @@ static int __devinit m25p_probe(struct s
        if (info->flags & M25P_NO_ERASE)
                flash->mtd.flags |= MTD_NO_ERASE;
  
index 08f4a1e..86e136f 100644 (file)
@@ -10,7 +10,7 @@
  #endif /* __ATH79_COMMON_H */
 --- a/arch/mips/ath79/gpio.c
 +++ b/arch/mips/ath79/gpio.c
-@@ -198,6 +198,34 @@ void ath79_gpio_function_setup(u32 set, 
+@@ -198,6 +198,34 @@ void ath79_gpio_function_setup(u32 set,
        spin_unlock_irqrestore(&ath79_gpio_lock, flags);
  }
  
index 2ee025b..489bc96 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/early_printk.c
 +++ b/arch/mips/ath79/early_printk.c
-@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned 
+@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
        /* nothing to do */
  }
  
index b38b461..f9ec775 100644 (file)
@@ -50,7 +50,7 @@
  #define PB44_GPIO_SW_RESET    (PB44_GPIO_EXP_BASE + 6)
  #define PB44_GPIO_SW_JUMP     (PB44_GPIO_EXP_BASE + 8)
  #define PB44_GPIO_LED_JUMP1   (PB44_GPIO_EXP_BASE + 9)
-@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data 
+@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
        .cs_line = 0,
  };
  
index fc05676..e7e1712 100644 (file)
  #include <asm/uaccess.h>
  
  #include <linux/proc_fs.h>
-@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct 
+@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
        topt = (__be32 *)(t1 + 1);
  
        if (ts) {
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
-@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff 
+@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
        struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
        __be16 *p = (__be16 *)(ipv6h+1);
  
index 7e56e91..630d8d2 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 
index ddc27b1..4af122e 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -651,6 +651,10 @@
+@@ -645,6 +645,10 @@ static const struct spi_device_id m25p_i
        /* Everspin */
-       { "mr25h256", CAT25_INFO(  32 * 1024, 1, 256, 2) },
+       { "mr25h256", CAT25_INFO(  32 * 1024, 1, 256, 2) },
  
 +      /* GigaDevice */
 +      { "gd25q32", INFO(0xc84016, 0, 64 * 1024,  64, SECT_4K) },
index 2459b61..99411ac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -2378,12 +2378,15 @@ static void dynamic_debug_remove(struct
+@@ -2398,12 +2398,15 @@ static void dynamic_debug_remove(struct
  
  void * __weak module_alloc(unsigned long size)
  {
index 5ad1713..28e2fa8 100644 (file)
@@ -16,7 +16,7 @@
  };
  
  #define INFO(_jedec_id, _ext_id, _sector_size, _n_sectors, _flags)    \
-@@ -667,6 +669,10 @@ static const struct spi_device_id m25p_i
+@@ -671,6 +673,10 @@ static const struct spi_device_id m25p_i
        { "n25q128",  INFO(0x20ba18, 0, 64 * 1024, 256, 0) },
        { "n25q256a", INFO(0x20ba19, 0, 64 * 1024, 512, SECT_4K) },
  
@@ -27,7 +27,7 @@
        /* Spansion -- single (large) sector size only, at least
         * for the chips listed here (without boot sectors).
         */
-@@ -907,6 +913,9 @@ static int __devinit m25p_probe(struct s
+@@ -911,6 +917,9 @@ static int __devinit m25p_probe(struct s
        if (info->flags & SECT_4K) {
                flash->erase_opcode = OPCODE_BE_4K;
                flash->mtd.erasesize = 4096;
index 7466f3b..293b6f2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -751,6 +751,7 @@ static const struct spi_device_id m25p_i
+@@ -755,6 +755,7 @@ static const struct spi_device_id m25p_i
        { "w25x64", INFO(0xef3017, 0, 64 * 1024, 128, SECT_4K) },
        { "w25q64", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
        { "w25q80", INFO(0xef5014, 0, 64 * 1024,  16, SECT_4K) },
index 2a2541b..58d8d06 100644 (file)
@@ -30,7 +30,7 @@
  /****************************************************************************/
  
  struct m25p {
-@@ -911,7 +917,7 @@ static int __devinit m25p_probe(struct s
+@@ -915,7 +921,7 @@ static int __devinit m25p_probe(struct s
                flash->mtd._write = m25p80_write;
  
        /* prefer "small sector" erase if possible */
index f9e12ac..731fe45 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -877,7 +877,7 @@ static void __init kernel_init_freeable(
+@@ -877,7 +877,7 @@ static noinline void __init kernel_init_
  
        /* Open the /dev/console on the rootfs, this should never fail */
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index f1bf3e8..85126e4 100644 (file)
@@ -59,7 +59,7 @@
   * When we die, we re-parent all our children, and try to:
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -3565,6 +3565,7 @@ int can_nice(const struct task_struct *p
+@@ -3566,6 +3566,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index eb07e39..febdecc 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index 35ec060..4ecf12f 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.4/arch/mips/lantiq/xway/timer.c  2013-01-28 18:37:52.316180918 +0100
+--- /dev/null
++++ b/arch/mips/lantiq/xway/timer.c
 @@ -0,0 +1,845 @@
 +#ifndef CONFIG_SOC_AMAZON_SE
 +
@@ -848,10 +846,8 @@ Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
 +module_exit(lq_gptu_exit);
 +
 +#endif
-Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h       2013-01-28 18:26:14.280164283 +0100
+--- /dev/null
++++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
 @@ -0,0 +1,155 @@
 +#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
 +#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
@@ -1008,10 +1004,8 @@ Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
 +      u32 reload, unsigned long arg1, unsigned long arg2);
 +
 +#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
-Index: linux-3.7.4/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.7.4.orig/arch/mips/lantiq/xway/Makefile    2013-01-28 18:26:06.580164100 +0100
-+++ linux-3.7.4/arch/mips/lantiq/xway/Makefile 2013-01-28 18:38:07.848181285 +0100
+--- a/arch/mips/lantiq/xway/Makefile
++++ b/arch/mips/lantiq/xway/Makefile
 @@ -1,3 +1,3 @@
 -obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
 +obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
index 78ba3e4..fbf6f81 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 DEVICE_TYPE:=developerboard
 
index 22223eb..dcd1a8c 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 675681f..4a57f21 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 83fb0c3..68e5a57 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 346eca6..9a5f811 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index ab032e3..69f01b7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index a45c07f..c82b189 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \