opkg: work around the same broken array overrun check in gcc 4.4 as in gcc 4.3
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Apr 2009 19:38:58 +0000 (19:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Apr 2009 19:38:58 +0000 (19:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15522 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/opkg/Makefile

index 8a06ec0..8b19619 100644 (file)
@@ -40,7 +40,7 @@ define Package/opkg/conffiles
 /etc/opkg.conf
 endef
 
-TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
+TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
 EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 EXTRA_LDFLAGS += $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib