add miau from Benjamin Binier, updated to newest upstream, thx. add syslog-ng from...
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 15 Mar 2006 13:40:51 +0000 (13:40 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 15 Mar 2006 13:40:51 +0000 (13:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3378 3c298f89-4303-0410-b956-a3cf2f4a3e73

17 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/bitchx/Config.in
openwrt/package/bitlbee/Config.in
openwrt/package/miau/Config.in [new file with mode: 0644]
openwrt/package/miau/Makefile [new file with mode: 0644]
openwrt/package/miau/files/S50miau [new file with mode: 0755]
openwrt/package/miau/files/miau [new file with mode: 0644]
openwrt/package/miau/files/miaurc [new file with mode: 0644]
openwrt/package/miau/ipkg/miau.conffiles [new file with mode: 0644]
openwrt/package/miau/ipkg/miau.control [new file with mode: 0644]
openwrt/package/syslog-ng/Config.in [new file with mode: 0644]
openwrt/package/syslog-ng/Makefile [new file with mode: 0644]
openwrt/package/syslog-ng/files/syslog-ng.conf [new file with mode: 0644]
openwrt/package/syslog-ng/files/syslog-ng.init [new file with mode: 0755]
openwrt/package/syslog-ng/ipkg/syslog-ng.conffiles [new file with mode: 0644]
openwrt/package/syslog-ng/ipkg/syslog-ng.control [new file with mode: 0644]

index 2f3fddc..05b736f 100644 (file)
@@ -41,6 +41,7 @@ source "package/libffi-sable/Config.in"
 endmenu
 source "package/sane-backends/Config.in"
 source "package/ser2net/Config.in"
+source "package/syslog-ng/Config.in"
 menu "rrdtool........................... Round-Robin Database (RRD) libraries and tools"
 source "package/rrdtool/Config.in"
 source "package/rrdtool1/Config.in"
@@ -102,6 +103,7 @@ source "package/lighttpd/Config.in"
 source "package/linux-atm/Config.in"
 source "package/macchanger/Config.in"
 source "package/maradns/Config.in"
+source "package/miau/Config.in"
 source "package/mini_httpd/Config.in"
 source "package/mini_sendmail/Config.in"
 source "package/mtr/Config.in"
index 7405559..856b7eb 100644 (file)
@@ -132,6 +132,7 @@ package-$(BR2_PACKAGE_MACCHANGER) += macchanger
 package-$(BR2_PACKAGE_MADPLAY) += madplay
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MIAU) += miau
 package-$(BR2_PACKAGE_MIAX) += miax
 package-$(BR2_PACKAGE_MICROCOM) += microcom
 package-$(BR2_PACKAGE_MICROPERL) += microperl
@@ -230,6 +231,7 @@ package-$(BR2_PACKAGE_SSMTP) += ssmtp
 package-$(BR2_PACKAGE_SSLTUNNEL) += ssltunnel
 package-$(BR2_PACKAGE_SRELAY) += srelay
 package-$(BR2_PACKAGE_STRACE) += strace
+package-$(BR2_PACKAGE_SYSLOG_NG) += syslog-ng
 package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
 package-$(BR2_PACKAGE_TINC) += tinc
 package-$(BR2_PACKAGE_TINYPROXY) += tinyproxy
index 5938687..91b95a9 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_BITCHX
-       prompt "BitchX............................ popular IRC client"
+       prompt "bitchx............................ popular IRC client"
        tristate
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_LIBNCURSES
index 3560e28..e2db432 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_BITLBEE
-       prompt "BitlBee........................... IRC gateway to IM chat networks"
+       prompt "bitlbee........................... IRC gateway to IM chat networks"
        tristate
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_LIBOPENSSL
diff --git a/openwrt/package/miau/Config.in b/openwrt/package/miau/Config.in
new file mode 100644 (file)
index 0000000..cac4b8f
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_MIAU
+       tristate "miau................................. Another IRC-bouncer/proxy"
+       default m if CONFIG_DEVEL
+       help
+         In short, miau is an IRC-bouncer/proxy. 
+         Being more verbose, miau is small but quite featured 
+         IRC-bouncer - a service bit like HTTP-proxy, but
+         for IRC-networks.
+         
+         http://sourceforge.net/projects/miau/
+         
diff --git a/openwrt/package/miau/Makefile b/openwrt/package/miau/Makefile
new file mode 100644 (file)
index 0000000..b8290aa
--- /dev/null
@@ -0,0 +1,74 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=miau
+PKG_VERSION:=0.6.0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=1b78d219a03655399c165eeb021cddd8
+
+PKG_SOURCE_URL:= @SF/miau
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MIAU,miau,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --bindir=/usr/bin \
+                       --sysconfdir=/etc \
+                       --enable-automode \
+                       --enable-releasenick \
+                       --enable-uptime \
+                       --enable-privlog \
+                       --enable-onconnect \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $@
+
+$(IPKG_MIAU): 
+       install -d -m0755 $(IDIR_MIAU)/usr/bin          
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(IDIR_MIAU)/usr/bin/
+       install -d -m0755 $(IDIR_MIAU)/etc/init.d
+       install -d -m0755 $(IDIR_MIAU)/etc/default
+       install -d -m0755 $(IDIR_MIAU)/etc/miau
+       install -m0755 ./files/S50miau $(IDIR_MIAU)/etc/init.d/S50miau
+       install -m0644 ./files/miau $(IDIR_MIAU)/etc/default/miau
+       install -m0644 ./files/miaurc $(IDIR_MIAU)/etc/miau/miaurc
+       $(RSTRIP) $(IDIR_MIAU)
+       $(IPKG_BUILD) $(IDIR_MIAU) $(PACKAGE_DIR)
diff --git a/openwrt/package/miau/files/S50miau b/openwrt/package/miau/files/S50miau
new file mode 100755 (executable)
index 0000000..beef310
--- /dev/null
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+DEFAULT="/etc/default/miau"
+OPTIONS="-d /etc/miau/"
+LOG_DIR="/var/log/miau"
+ERR_LOG="$LOG_DIR/error.log"
+OUT_LOG="$LOG_DIR/miau.log"
+
+[ -f $DEFAULT ] && . $DEFAULT
+[ "$ENABLE_MIAU" = "yes" ] || exit 0
+
+case $1 in
+ start)
+  [ -f /var/run/miau.pid ] && echo "[ERROR] miau is running"
+  [ -f /var/run/miau.pid ] && exit 0
+  [ -d /var/run ] || mkdir -p /var/run
+  [ -d $LOG_DIR ] || mkdir -p $LOG_DIR 
+  /usr/bin/miau -f $OPTIONS > $OUT_LOG 2> $ERR_LOG &
+  PID=$!
+  sleep 1 
+  [ -d /proc/$PID ] && echo $PID > /var/run/miau.pid 
+  [ -d /proc/$PID ] || echo "[ERROR] Unable to run miau as a daemon"
+  ;;
+ stop)
+  [ -f /var/run/miau.pid ] && kill $(cat /var/run/miau.pid) >/dev/null 2>&1 && rm /var/run/miau.pid
+  ;;
+ *)
+ echo "usage: $0 (start|stop)"
+ exit 1
+esac
+
+exit $? 
diff --git a/openwrt/package/miau/files/miau b/openwrt/package/miau/files/miau
new file mode 100644 (file)
index 0000000..7d4f869
--- /dev/null
@@ -0,0 +1,2 @@
+ENABLE_MIAU="yes"
+OPTIONS="-d /etc/miau"
diff --git a/openwrt/package/miau/files/miaurc b/openwrt/package/miau/files/miaurc
new file mode 100644 (file)
index 0000000..c12e4ff
--- /dev/null
@@ -0,0 +1,587 @@
+#
+# miau 0.5.3 configuration file example
+#      (C) 2003-2004 Tommi Saviranta <tsaviran@cs.helsinki.fi>
+#
+
+# About structure of this configuration file:
+#
+# - All parameters are written inside quotes (for example, "foobar")
+#
+# - Options are defined like: option = "parameter1"[:"parameter2"] ...
+#
+# - When entering multiparameter options, certain parameters have default
+#   values and can be left out.
+#
+# - When entering multiparameter options and, for example, user doesn't want
+#   to set parameter2 at all but he needs to set parameter3, parameter2 can
+#   be skipped with column (':') like: "parameter1"::"parameter3".
+#
+# - Empty lines and characters after '#' (hash) are ignored.
+#
+# - When setting permissions, switched etc. (switches (booleans) are described
+#   as "state"), everything beginning with "t", "r" and "1" are concidered as
+#   "true" or "yes" (positive). Everything else is "false" or "no" (negative).
+
+
+
+# Required settings
+################################################################################
+
+
+# nicknames = { "nick" }: Your nickname (and secondary nicknames) on IRC.
+#              If the primary nick (first nick on the list) is already on use,
+#              miau will try the others on the list.
+#
+# Default: no default
+#
+# Example:
+#nicknames = {
+#      "zak"
+#      "zakh"
+#}
+
+
+# realname = "realname": Your "real" name on IRC.
+#
+# Default: no default
+#
+# Example:
+#realname = "Prokhor Zakharov"
+
+
+# username = "username": Your ident (matters only if you don't have identd
+#              running).
+#
+# Default: no default
+#
+# Example:
+#username = "zak"
+
+
+# password = "password": The password miau will expect to receive from client
+#              when it's registering with nick. If this is 13 characters long,
+#              miau assumed it's crypted.
+#
+# If miau is compiled with ENABLE_MKPASSWD, miau can generate password-hashes
+# (from command line) with -c -switch.
+#
+# Default: no default
+#
+# Example:
+#password = "foobar"
+
+
+# listenport = "port": The port miau will wait for incoming connections.
+#
+# Default: no default
+#
+# Example:
+#listenport = "4096"
+
+
+# servers = { "server":"port":"password":"timeout" }: miau's IRC-server-list.
+#              Each line represents one server, where timeout is delay in
+#              seconds before connectiong attempt times out. Only "server"
+#              parameter is required.
+#
+# Default: no default
+#
+# Example:
+#servers = {
+#      "irc.net"
+#      "irc.foo.bar":"6662"
+#      "localhost"::"foobar"
+#      "127.0.0.1":"6670"::"5"
+#}
+
+
+# connhosts = { "host":"permitted" }: List of hosts that are allowed (or denied)
+#              to connect to miau. When boolean-value is left unset, it is
+#              assumed to be "true". This list will be processed as a chain
+#              which means latter rules can override previous ones.
+#
+# Default: no default
+#
+# Example:
+#connhosts = {
+#      "*":"yes"
+#      "client*.evil.net":"no"
+#}
+
+
+
+# Optional settings
+################################################################################
+
+
+# listenhost = "host": Host miau uses to listen on.
+#
+# If you are compiled with IPV6 and need this to listen on an IPV4 port, you
+# must use an IP in the form ::FFFF:127.0.0.1
+#
+# Default: no default
+#
+# Example:
+#listenhost = "127.0.0.1"
+
+
+# bind = "host": Host/IP miau uses for outgoing connections.
+#
+# Default: none
+#
+# Example:
+#bind = "172.16.1.1"
+
+
+# maxclients = "number": Maximum number of clients connected to miau
+#              concurrently. Set to zero for unlimited clients.
+#
+# Default: 3
+#
+#Example:
+#maxclients = "1"
+
+
+# stonedtimeout = "seconds": Time (in seconds) with no data from the server
+#              before it is declared stoned and being disconnected. Although
+#              minimum value is 30, this value has no upper limit. Watch out,
+#              though, if this value is set too high, death of servers may stay
+#              undetected for a very long time if you are idle.
+#
+# Default: 90
+#
+# Example:
+#stonedtimeout = "150"
+
+
+# connecttimeout = "seconds": Time (in seconds) before connection attampt will
+#              time out. Note that while connecting to the server miau will not
+#              respond to clients. Minimum value is 5, and many systems define
+#              maximum value.
+#
+# Default: 30
+#
+# Example:
+#connecttimeout = "60"
+
+
+# channels = { "channel":"keyword" }: List of channels to join.
+#
+# Default: none
+#
+# Example:
+#channels = {
+#      "#foobar"
+#      "#miau":"cats"
+#}
+
+
+# rejoin = "state": Rejoin channels after disconnecting from the server.
+#              If rejoin is set to true, channels defined in "channels" are
+#              also joined when client first time connects to miau.
+#
+# Default: true
+#
+# Example:
+#rejoin = "false"
+
+
+# leave = "state": Leave channels when all clients have detached from miau.
+#              If "leave" is set to "false" and "rejoin" is set to "true",
+#              channels defined at "channels" will be joined at miau startup.
+#              If both "leave" and "rejoin" is set to "true", channels that
+#              are left at client detach, are rejoined when client attached
+#              back to miau.
+#
+# Default: false
+#
+# Example:
+#leave = "false"
+
+
+# leavemsg = "message": Message miau will either use as PART-message or as an
+#              ACTION when all clients have detached from miau. If unset or
+#              set to empty, no message will be shown. Note that many people
+#              dislike event-based messages (which happens when "leave" is set
+#              to "false" and "leavemsg" is set). Also see usequitmsg.
+#
+# Note: Note that commenting this option out and rehashing after leavemsg was
+#      set, this option is _not_ reverted. To disable leavemsg afterwards you
+#      need to write an empty string here and rehash.
+#
+# Default: none
+#
+# Example:
+#leavemsg = "doh"
+
+
+# awaymsg = "message": Text that will be set to miau's away-reason when all
+#              clients have detached from miau. If unset or set to empty,
+#              AWAY-status will be left untouched. When any client attaches
+#              back to miau, AWAY-status will be reset. Also see usequitmsg.
+#
+# Note: If user sets him/herself away, miau will not touch away-status nor
+#      message neither when connecting to or disconnecting from miau.
+#
+# Note: Note that commenting this option out and rehashing after awaymsg was
+#      set, this option is _not_ reverted. To disable awaymsg afterwards you
+#      need to write an empty string here and rehash.
+#
+# Default: none
+#
+# Example:
+#awaymsg = "bouncing around - all private messages will be logged"
+
+
+# usequitmsg = "state": Use last quit-reason as away-reason and/or leave-message
+#              (if respective options are enabled) when all clients have
+#              disconnected from miau. If quit-reason is empty, default values
+#              of awaymsg and leavemsg will be used, otherwise most recent
+#              quit-message overrides values in miaurc.
+#
+# Default: true
+#
+# Example:
+# usequitmsg = "false"
+
+
+# getnick = "selection": miau can try to reclaim your primary nick when it is
+#              lost. This option may be one of the following: "never",
+#              "detached", "attached", or "always".
+#                      "never" ....... miau will not try to get your nick back.
+#                      "detached" .... miau will try to get your nick when no
+#                                      clients are attached.
+#                      "attached" .... miau will try to get your nick when
+#                                      there are one or more clients attached.
+#                      "always" ...... miau will try to get your nick 
+#
+# Note: Do _not_ use options "attached" and "always" with clients (like
+#      irc-II EPIC) that automatically change your nick when they receive
+#      NICKINUSE from the server - you might end up chaning your nick until
+#      server drops your connection due excess flood.
+#
+# Default: detached
+#
+# Example:
+#getnick = "always"
+
+
+# getnickinterval = "seconds": Time between tries (in seconds) to obtain
+#              currently (possibly) lost primary nick. Don't set it too low
+#              or you might get kicked out the server due to excess flood.
+#
+# Default: 60
+#
+# Example:
+#getnickinterval = "30"
+
+
+# antiidle = "minutes": Time between idle-timer resets in minutes. Set to 0 to
+#              disable.
+#
+# Default: 0
+#
+# Example:
+#antiidle = "300"
+
+
+# qloglength = "minutes": Age of oldest line in quicklog in minutes. Set to zero
+#              to disable quicklog.
+#
+# This option might not be compiled in.
+#
+# Default: 30
+#
+# Example:
+#qloglength = "30"
+
+
+# timestamp = "option": Location of timestamp in quicklog events. This option
+#              may be one of the following "beginning", "end", or "none".
+#
+# This option might not be compiled in.
+#
+# Default: none
+#
+# Example:
+#timestamp = "beginning"
+
+
+# flushqlog = "state": If set to true, quicklog will be written only when no
+#              clients are connected and quicklog will be erased when client
+#              connects to miau. If you are running a single client, you
+#              probably want to leave this to "false.
+#
+# This option might not be compiled in.
+#
+# Default: true
+#
+# Example:
+#flushqlog = "true"
+
+
+# inbox = "state": Enables logging private messages when no clients are
+#              connected to miau.
+#
+# This option might not be compiled in.
+#
+# Default: true
+#
+# Example:
+#inbox = "true"
+
+
+# nevergiveup = "state": If set to true, miau will reset "working"-status of
+#              servers to working when all are set to dysfunctional.
+#              Respectively, if set to false, miau will quit when all servers
+#              on the list have been set to dysfunctional.
+#
+# Default: true
+#
+# Example:
+#nevergiveup = "false"
+
+
+# norestricted = "state": If set to true, miau will not stay on server that
+#              forces user to have restricted-status (+r).
+#
+# Default: true
+#
+# Example:
+#norestricted = "false"
+
+
+# reconnectdelay = "seconds": Time (in seconds) between connection attempts.
+#              Minumun value is set to 1.
+#
+# Default: 10
+#
+# Example:
+#reconnectdelay = "30"
+
+
+# nickfillchar = "fill character": Character used to modify your primary nick
+#              when all defined nicks are already occupied. Note character is
+#              a single octet (byte) and if longer string is fed, only the
+#              first character is used.
+#
+# Example: When nickfillchar is set to '_', primary nick is "zak" and all
+#      defined nicks are occupied, next nicks tried are "zak_", "zak__",
+#      "zak___" and so on. When nick has grown too long, it will be shifted
+#      one characted to right (where shift is cyclic) - this means
+#      "zak______" will become "_zak_____", which, again, will become
+#      "__zak____".
+#
+# Default: _
+#
+# Example:
+#nickfillchar = "^"
+
+
+# maxnicklen = "length": Maximum nick length, used with nickfillchar.
+#
+# Default: 9
+#
+# Example:
+#maxnicklen = 11
+
+
+# usermode = "usermode(s)": Usermode that miau will request (if no clients are
+#              attached at the moment) from the server when connection to the
+#              server is established. Leave unset or set to empty to disable
+#              this feature.
+#
+# Default: none
+#
+# Example:
+#usermode = "+i"
+
+
+# forwardmsg = "command": miau can collect the (private) messages within three
+#              (3) minutes and pipe them into the program specified. Leave this
+#              unset or set to empty to disable this feature.
+#
+# Default: none
+#
+# Example:
+#forwardmsg = "mail user@host"
+
+
+# ignore = { "mask":"ignored" }: List of users whose private messages (PRIVMSG)
+#              and noticies (NOTICE) are ignored when no clients are attached
+#              to miau. When "ignored" is left undefined, it is assumed to be
+#              "true". Setting "ignored" to "false" means that this user will
+#              _not_ be ignored. This list is processed as a chain.
+#
+# Default: none
+#
+# Example:
+#ignore = {
+#      "*@localhost":"yes"
+#      "zak*":"no"
+#}
+
+
+# privlog = "mode": Whatever private messages should be logged in nick-specific
+#              files. Can be one of "never", "detached", "attached", and
+#              "always".
+#
+# This option might not be compiled in.
+#
+# Default: never
+#
+# Example:
+#privlog = "always"
+
+
+# chanlog = { "channel(s)":"options":"logfile" }: List of channel logfiles.
+#
+# When channel is set to "*", line represents global log. When logging,
+# if channel doesn't have entry of it's own in this list, it will use settings
+# of global log and write log to it's own file. When defining global log,
+# "logfile" is ignored. Each line can have multiple channels
+# (like "#foobar,#miau").
+#
+# If logfile is left undefined, logfile will be named after the channel with
+# possible postfix (see logpostfix). All lofiles are written in miau's work
+# directory.
+#
+# Options consist of abritary set of following possibilities:
+#      j: log joins
+#      e: log parts (exits)
+#      q: log quits
+#      m: log messages (privmsg/notice)
+#      c: log mode changes (changes)
+#      n: log nick changes
+#      o: log misc events (other)
+#      b: log messages from miau (bouncer)
+#      a: log all of above
+#      A: log when a client is attached
+#      D: log when a client is detached
+#      C: log continuously (status of clients doesn't matter)
+#
+# This option might not be compiled in.
+#
+# Default: none
+#
+# Example:
+#chanlog = {
+#      "#foobar":"a"           # log everything on #foobar
+#      "#miau":"aD":"foo.log"  # log everything to file "foo.log" when
+#                                all clients are detached
+#      "*":"mjeq"              # log only messages, joins, parts and quits
+#                                by default
+#}
+
+
+# logpostfix = "postfix": When writing log to undefined logfile, each logfile
+#              consists of channel name followed by postfix. Postfix can be
+#              defined here.
+#
+# This option might not be compiled in.
+#
+# Default: no postfix
+#
+# Example:
+#logpostfix = ".log"
+
+
+# onconnect = { "mode":"target/data"(:"data") }: When miau connects and
+#              registers user to server, miau can send pre-defined messages.
+#              User can define miau to send normal messages (PRIVMSG), notices
+#              (NOTICE) or arbitrary messages.
+#
+# Mode can be one of the following:
+#      p: private message (PRIVMSG).
+#      n: notice (NOTICE). Should be used with services and automatons, but
+#         unfortunately some network services can't cope with notices.
+#      r: "raw" message. This means user must provide complete message to send
+#         to the server. Using raw message user has complete control over what
+#         is being sent. If you don't know what this is, you don't need this.
+# When using modes "p" or "n", user must provide both message and target where
+# as with raw messages only one parameter in addition to type should be given.
+#
+# This option might not be compiled in.
+#
+# Default: none
+#
+# Example:
+#onconnect = {
+#      "p":"nickserv":"identify foobar"
+#      "n":"nickserv@services.host.net":"id raboof"
+#      "r":"OPER foo bar"
+#}
+
+
+# automodes = { "mask":"privilegded" }: List of people who are automatically
+#              given certain privilege on channel. Mask is given in form of
+#              "mode:nick!username@host/#channel" (where "mode" is a single
+#              character) and list is processed as a chain.
+#
+# This option might not be compiled in.
+#
+# Default: none
+#
+# Example:
+#automodes = {
+#      "o:zak*!zak@client*-myisp.com/#channel":"yes"
+#      "o:zak*!*@evil.impersonator.net/#foobar":"no"
+#      "v:newbie*!*@ircnet.com/#newbie":"yes"
+#}
+
+
+# automodedelay = "seconds": Time (in seconds) after first queued mode change
+#              would take effect. During this period of time miau can collect
+#              more than one mode change and commit up to three at a time.
+#              Other situation reasonaly big value (like 30) here could prove
+#              useful is channel where there are stupid "auto-oping" bots.
+#              (Stupid bots do mode changes even if someone else did that
+#              already.)
+#
+# This option might not be compiled in.
+#
+# Default: 30
+#
+# Example:
+#automodedelay = "60"
+
+
+# cmdpasswd = "password": Password for remote commands. If this is 13 characters
+#              long, miau assumes it's crypted. Comment this out or leave it
+#              empty to disable remote commands. When sending miau a remote
+#              command, password _always_ begins with column (':') (if
+#              cmdpasswd is set to "foobar" (or hash of it), you need to send
+#              miau a message beginning with ":foobar" to issue a remote
+#              command).
+#
+# This feature might not be compiled in.
+#
+# If miau is compiled with ENABLE_MKPASSWD, miau can generate password-hashes
+# (from command line) with -c -switch.
+#
+# Default: disabled
+#
+# Example:
+#cmdpasswd = ""
+
+
+# dccbounce = "state": miau can bounce DCCs. Set to true to enable bouncing.
+#              You probably don't need this.
+#
+# This option might not be compiled in.
+#
+# Default: false
+#
+# Example:
+#dccbounce = "true"
+
+
+# dccbindhost = "host": If miau has separate IPs for IRC-network and clients,
+#              you should enter IP for clients here.
+#
+# This option might not be compiled in.
+#
+# Default: no default
+#
+# Example:
+#dccbindhost = "10.0.0.1"
diff --git a/openwrt/package/miau/ipkg/miau.conffiles b/openwrt/package/miau/ipkg/miau.conffiles
new file mode 100644 (file)
index 0000000..a6c7d70
--- /dev/null
@@ -0,0 +1,3 @@
+/etc/default/miau
+/etc/init.d/S50miau
+/etc/miau/miaurc
diff --git a/openwrt/package/miau/ipkg/miau.control b/openwrt/package/miau/ipkg/miau.control
new file mode 100644 (file)
index 0000000..688407b
--- /dev/null
@@ -0,0 +1,7 @@
+Package: miau
+Version: 1
+Architecture: mipsel
+Maintainer: Benjamin Binier benjamin.binier@gmail.com
+Priority: optional
+Section: net
+Description: miau is an IRC-bouncer/proxy 
diff --git a/openwrt/package/syslog-ng/Config.in b/openwrt/package/syslog-ng/Config.in
new file mode 100644 (file)
index 0000000..d9fface
--- /dev/null
@@ -0,0 +1,30 @@
+config BR2_PACKAGE_SYSLOG_NG
+       prompt "syslog-ng......................... A powerful syslog daemon"
+       tristate
+       default n 
+       help
+               syslog-ng reads and logs messages to the  system  console,  log
+               files, other machines and/or users as specified by its
+               configuration file.
+
+               The  configuration  file is read at startup and is reread after
+               receipt of a hangup (HUP) signal.  When reloading the
+               configuration  file,  all destination  files  are  closed  and
+               reopened as appropriate. For more information about the
+               configuration file, see syslog-ng.conf(5).
+
+               Typically messages are sent to  syslog-ng  via  a  Unix  domain
+               socket (/dev/log) or via UDP, to port 514 or to whatever
+               syslog/udp is defined to be in /etc/services.  To receive
+               messages from the kernel, /dev/klog is opened for reading.
+
+               Messages sent to syslog-ng should be an entire line, prefixed
+               by a pri- ority code in between '<' and '>'.   Definititions
+               of  the  recognised values can be found in the include file
+               <sys/syslog.h>.
+
+               syslog-ng  can  be  configured to pass messages on to other
+               syslog-ng's and when doing so, it sends the message on with the
+               priority as a  pre- fix.
+
+               http://www.balabit.com/products/syslog_ng/        
diff --git a/openwrt/package/syslog-ng/Makefile b/openwrt/package/syslog-ng/Makefile
new file mode 100644 (file)
index 0000000..b97cca3
--- /dev/null
@@ -0,0 +1,76 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=syslog-ng
+PKG_VERSION:=1.6.9
+PKG_RELEASE:=1
+PKG_MD5SUM:=5280a86b4f5c25b2ba157c8cea302cf0
+
+PKG_SOURCE_URL:=http://www.balabit.com/downloads/syslog-ng/stable/src \
+               http://www.balabit.com/downloads/syslog-ng/1.6/src
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INIT_LEVEL:=00
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SYSLOG_NG,syslog-ng,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/libol" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libol" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --localstatedir=/var/lib \
+                 --disable-dependency-tracking \
+                 --disable-full-static \
+                 --enable-tcp-wrapper \
+                 --with-libol=$(STAGING_DIR)/usr/bin \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/include/libol" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libol" \
+               CC=$(TARGET_CC) \
+               all install
+       touch $@
+
+$(IPKG_SYSLOG_NG):
+       install -d -m0755 $(IDIR_SYSLOG_NG)/usr/sbin
+       install -d -m0755 $(IDIR_SYSLOG_NG)/etc/syslog-ng
+       install -d -m0755 $(IDIR_SYSLOG_NG)/etc/init.d
+       $(CP) ${PKG_BUILD_DIR}/src/syslog-ng $(IDIR_SYSLOG_NG)/usr/sbin/
+       $(CP) files/syslog-ng.conf $(IDIR_SYSLOG_NG)/etc/syslog-ng/
+       $(CP) files/syslog-ng.init $(IDIR_SYSLOG_NG)/etc/init.d/S$(PKG_INIT_LEVEL)syslog-ng
+       $(RSTRIP) $(IDIR_SYSLOG_NG)
+       $(IPKG_BUILD) $(IDIR_SYSLOG_NG) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/syslog-ng/files/syslog-ng.conf b/openwrt/package/syslog-ng/files/syslog-ng.conf
new file mode 100644 (file)
index 0000000..658abea
--- /dev/null
@@ -0,0 +1,16 @@
+options { 
+       chain_hostnames(off); 
+       sync(0); 
+
+       # The default action of syslog-ng 1.6.0 is to log a STATS line
+       # to the file every 10 minutes.  That's pretty ugly after a while.
+       # Change it to every 12 hours so you get a nice daily update of
+       # how many messages syslog-ng missed (0).
+       stats(43200); 
+};
+
+source src { unix-stream("/dev/log"); internal(); };
+
+destination messages { file("/var/log/messages"); };
+
+log { source(src); destination(messages); };
diff --git a/openwrt/package/syslog-ng/files/syslog-ng.init b/openwrt/package/syslog-ng/files/syslog-ng.init
new file mode 100755 (executable)
index 0000000..40472ed
--- /dev/null
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+syslog_start() {
+  [ -f /etc/syslog-ng/syslog-ng.conf ] || {
+    echo "/etc/syslog-ng/syslog-ng.conf does not exist !";
+    exit 0;
+  };
+  [ -d /var/run ] || mkdir -p /var/run
+  [ -x /usr/sbin/syslog-ng ] && /usr/sbin/syslog-ng
+}
+
+syslog_stop() {
+  killall syslog-ng
+}
+
+case "$1" in
+  start)
+       syslog_start
+       ;;
+  stop)
+       syslog_stop
+       ;;
+  restart)
+       syslog_stop
+       sleep 1s
+       syslog_start
+       ;;
+  reload)
+       kill -HUP `cat /var/run/syslog-ng.pid` &>/dev/null
+       ;;
+  *)
+       echo "Usage: $0 <start|stop|restart|reload>"
+       ;;
+esac
diff --git a/openwrt/package/syslog-ng/ipkg/syslog-ng.conffiles b/openwrt/package/syslog-ng/ipkg/syslog-ng.conffiles
new file mode 100644 (file)
index 0000000..453ebbe
--- /dev/null
@@ -0,0 +1 @@
+/etc/syslog-ng/syslog-ng.conf
diff --git a/openwrt/package/syslog-ng/ipkg/syslog-ng.control b/openwrt/package/syslog-ng/ipkg/syslog-ng.control
new file mode 100644 (file)
index 0000000..074fff1
--- /dev/null
@@ -0,0 +1,4 @@
+Package: syslog-ng
+Priority: optional
+Section: admin
+Description: A powerful syslog daemon