same for host builds
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 21:48:39 +0000 (21:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jul 2007 21:48:39 +0000 (21:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8246 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index d834465..e934c91 100644 (file)
@@ -84,7 +84,7 @@ ifneq ($(CONFIG_AUTOREBUILD),)
   define HostBuild/Autoclean
     $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
-    $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+    $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
   endef
 endif