[ramips] fix RT-N15 support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Apr 2013 18:56:44 +0000 (18:56 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Apr 2013 18:56:44 +0000 (18:56 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36325 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/RT-N15.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

diff --git a/target/linux/ramips/dts/RT-N15.dts b/target/linux/ramips/dts/RT-N15.dts
new file mode 100644 (file)
index 0000000..2ff266c
--- /dev/null
@@ -0,0 +1,95 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "RT-N15", "ralink,rt2880-soc";
+       model = "Asus RT-N15";
+
+       palmbus@300000 {
+               sysc@0 {
+                       ralink,pinmux = "uartlite";
+                       ralink,gpiomux = "i2c";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "uboot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+               partition@30000 {
+                       label = "uboot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+               partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+               partition@50000 {
+                       label = "linux";
+                       reg = <0x50000 0x3b0000>;
+               };
+       };
+
+       ethernet@400000 {
+               status = "okay";
+
+               ralink,fixed-link = <1000 1 1 1>;
+       };
+
+       wmac@480000 {
+               status = "okay";
+       };
+
+       rtl8366s {
+               compatible = "realtek,rtl8366s";
+               gpio-sda = <&gpio0 1 0>;
+               gpio-sck = <&gpio0 2 0>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 0>;
+                       linux,code = <0x211>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 0>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "rt-n15:blue:power";
+                       gpios = <&gpio0 11 1>;
+               };
+       };
+};
index eaa1fcf..7a9c6ae 100644 (file)
@@ -223,7 +223,7 @@ Image/Build/Profile/F5D8235V1=$(call BuildFirmware/CustomFlash/$(1),$(1),f5d8235
 
 Image/Build/Profile/BR6524N=$(call BuildFirmware/Edimax/$(1),$(1),br6524n,BR6524N,$(ralink_default_fw_size_4M),CSYS,WNRA,0x50000,0xc0000)
 
-Image/Build/Profile/RTN15=$(call BuildFirmware/Default4M/$(1),$(1),rt-n15,RTN15)
+Image/Build/Profile/RTN15=$(call BuildFirmware/Default4M/$(1),$(1),rt-n15,RT-N15)
 
 Image/Build/Profile/V11STFE=$(call BuildFirmware/Default4M/$(1),$(1),v11st-fe,V11STFE)