tools: install a fake empty ldconfig script to prevent the system ldconfig from messi...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 23:13:29 +0000 (23:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Sep 2014 23:13:29 +0000 (23:13 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42480 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index 4a30c8c..09a0c8c 100644 (file)
@@ -133,6 +133,10 @@ $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
                false; \
        fi
 
+$(STAGING_DIR_HOST)/bin/ldconfig:
+       touch $@
+       chmod +x $@
+
 $(eval $(call PrepareCommand,md5sum,gmd5sum md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
 $(eval $(call PrepareCommand,seq,gseq seq))
@@ -143,7 +147,7 @@ $(eval $(call PrepareCommand,grep,ggrep grep))
 $(eval $(call PrepareCommand,tar,gtar tar))
 $(eval $(call PrepareCommand,diff,gdiff diff))
 
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff ldconfig)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)