[target/generic]: refresh 2.6.38 patches with -rc2
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Jan 2011 09:39:17 +0000 (09:39 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Jan 2011 09:39:17 +0000 (09:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25081 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/patches-2.6.38/021-mips_image_cmdline_hack.patch
target/linux/generic/patches-2.6.38/025-mips_disable_fpu.patch
target/linux/generic/patches-2.6.38/420-gpiodev.patch
target/linux/generic/patches-2.6.38/840-unable_to_open_console.patch
target/linux/generic/patches-2.6.38/922-gpiommc.patch
target/linux/generic/patches-2.6.38/980-vm_exports.patch
target/linux/generic/patches-2.6.38/997-lzo_decompressor_fix.patch [deleted file]
target/linux/generic/patches-2.6.38/999-use_preinit_as_init.patch

index eb330b1..2e9a6e5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -904,6 +904,10 @@ config SYNC_R4K
+@@ -901,6 +901,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
  config MIPS_MACHINE
        def_bool n
  
index faf0f79..10b4468 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -889,6 +889,17 @@ config I8259
+@@ -886,6 +886,17 @@ config I8259
  config MIPS_BONITO64
        bool
  
  config MIPS_BONITO64
        bool
  
index 6aa65c9..5c1f3a6 100644 (file)
@@ -17,7 +17,7 @@
        depends on BLOCK
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
        depends on BLOCK
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -82,6 +82,7 @@ obj-$(CONFIG_NWFLASH)                += nwflash.o
+@@ -69,6 +69,7 @@ obj-$(CONFIG_NWFLASH)                += nwflash.o
  obj-$(CONFIG_SCx200_GPIO)     += scx200_gpio.o
  obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
  obj-$(CONFIG_SCx200_GPIO)     += scx200_gpio.o
  obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
index 8f1a4cb..767f777 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
 --- a/init/main.c
 +++ b/init/main.c
-@@ -890,7 +890,7 @@ static int __init kernel_init(void * unu
+@@ -899,7 +899,7 @@ static int __init kernel_init(void * unu
  
        /* Open the /dev/console on the rootfs, this should never fail */
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
  
        /* Open the /dev/console on the rootfs, this should never fail */
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index e925e57..fe27f3b 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -2851,6 +2851,11 @@ T:      git git://git.kernel.org/pub/scm/linu
+@@ -2855,6 +2855,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
  F:    drivers/media/video/gspca/
  
  S:    Maintained
  F:    drivers/media/video/gspca/
  
index 37a4dd0..4d10bc8 100644 (file)
                                void *caller)
 --- a/include/linux/mm.h
 +++ b/include/linux/mm.h
                                void *caller)
 --- a/include/linux/mm.h
 +++ b/include/linux/mm.h
-@@ -854,6 +854,7 @@ extern void show_free_areas(void);
+@@ -856,6 +856,7 @@ extern void show_free_areas(void);
  
  int shmem_lock(struct file *file, int lock, struct user_struct *user);
  struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
  
  int shmem_lock(struct file *file, int lock, struct user_struct *user);
  struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
diff --git a/target/linux/generic/patches-2.6.38/997-lzo_decompressor_fix.patch b/target/linux/generic/patches-2.6.38/997-lzo_decompressor_fix.patch
deleted file mode 100644 (file)
index aab44ca..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/usr/Kconfig
-+++ b/usr/Kconfig
-@@ -84,7 +84,7 @@ config RD_XZ
- config RD_LZO
-       bool "Support initial ramdisks compressed using LZO" if EMBEDDED
-       default !EMBEDDED
--      depends on BLK_DEV_INITRD
-+      depends on BLK_DEV_INITRD && HAVE_KERNEL_LZO
-       select DECOMPRESS_LZO
-       help
-         Support loading of a LZO encoded initial ramdisk or cpio buffer
index d58bb30..d46c13b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
 --- a/init/main.c
 +++ b/init/main.c
-@@ -843,10 +843,7 @@ static noinline int init_post(void)
+@@ -852,10 +852,7 @@ static noinline int init_post(void)
                printk(KERN_WARNING "Failed to execute %s.  Attempting "
                                        "defaults...\n", execute_command);
        }
                printk(KERN_WARNING "Failed to execute %s.  Attempting "
                                        "defaults...\n", execute_command);
        }