[buildroot] introduce a menuconfig option to turn off static linking of host utilities
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Aug 2012 00:26:34 +0000 (00:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 13 Aug 2012 00:26:34 +0000 (00:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33154 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/host-build.mk

index 0553712..e865777 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -153,6 +153,13 @@ menu "Global build settings"
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
                  instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
                  instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
+       config BUILD_STATIC_TOOLS
+               default y
+               bool "Attempt to link host utilities statically"
+               help
+                 Linking host utilities like sed or firmware-utils statically increases the portability of the
+                 generated ImageBuilder and SDK tarballs, however it may fail on some Linux distributions.
+
        config SHADOW_PASSWORDS
                bool
                prompt "Enable shadow password support"
        config SHADOW_PASSWORDS
                bool
                prompt "Enable shadow password support"
index a8bc79e..40af5c8 100644 (file)
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
 HOST_CONFIGURE_CMD = ./configure
 
 ifneq ($(HOST_OS),Darwin)
 HOST_CONFIGURE_CMD = ./configure
 
 ifneq ($(HOST_OS),Darwin)
-  HOST_STATIC_LINKING = -static
+  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+    HOST_STATIC_LINKING = -static
+  endif
 endif
 
 define Host/Configure/Default
 endif
 
 define Host/Configure/Default