update to new upstream release (v5.0.5),
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Sep 2005 23:11:06 +0000 (23:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Sep 2005 23:11:06 +0000 (23:11 +0000)
enable all packages when DEVELOPER=1,
add curl and gmp extensions,
fix gd extension build

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1950 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/Makefile
openwrt/package/php5/Config.in
openwrt/package/php5/Makefile
openwrt/package/php5/ipkg/php5-mod-curl.control [new file with mode: 0644]
openwrt/package/php5/ipkg/php5-mod-gmp.control [new file with mode: 0644]

index 99447a8..0ecc040 100644 (file)
@@ -322,9 +322,15 @@ php4-compile: expat-compile
 endif
 
 php5-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP5_MOD_CURL),)
+php5-compile: curl-compile
+endif
 ifneq ($(BR2_PACKAGE_PHP5_MOD_GD),)
 php5-compile: libgd-compile libpng-compile
 endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_GMP),)
+php5-compile: gmp-compile
+endif
 ifneq ($(BR2_PACKAGE_PHP5_MOD_LDAP),)
 php5-compile: openldap-compile
 endif
index 5fc159b..f3a8e1e 100644 (file)
@@ -10,7 +10,7 @@ comment "Server API --"
 config BR2_PACKAGE_PHP5_CLI
        prompt "...-cli - PHP5 CLI (Command Line Interface)"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -23,7 +23,7 @@ config BR2_PACKAGE_PHP5_CLI
 config BR2_PACKAGE_PHP5_CGI
        prompt "...-cgi - PHP5 built for CGI"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -36,7 +36,7 @@ config BR2_PACKAGE_PHP5_CGI
 config BR2_PACKAGE_PHP5_FASTCGI
        prompt "...-fastcgi - PHP5 built for FastCGI"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        select BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBOPENSSL
        select BR2_PACKAGE_ZLIB
@@ -48,78 +48,92 @@ config BR2_PACKAGE_PHP5_FASTCGI
 
 comment "Extensions --"
 
+config BR2_PACKAGE_PHP5_MOD_CURL
+       prompt "...-mod-curl - cURL module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_COMPILE_PHP5
+       select BR2_PACKAGE_LIBCURL
+
 config BR2_PACKAGE_PHP5_MOD_FTP
        prompt "...-mod-ftp - FTP module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
 
 config BR2_PACKAGE_PHP5_MOD_GD
        prompt "...-mod-gd - GD graphics library module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBGD
        select BR2_PACKAGE_LIBPNG
 
+config BR2_PACKAGE_PHP5_MOD_GMP
+       prompt "...-mod-gmp - GMP module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_COMPILE_PHP5
+       select BR2_PACKAGE_LIBGMP
+
 config BR2_PACKAGE_PHP5_MOD_LDAP
        prompt "...-mod-ldap - LDAP module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBOPENLDAP
 
 config BR2_PACKAGE_PHP5_MOD_MYSQL
        prompt "...-mod-mysql - MySQL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBMYSQLCLIENT
 
 config BR2_PACKAGE_PHP5_MOD_OPENSSL
        prompt "...-mod-openssl - OpenSSL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBOPENSSL
 
 config BR2_PACKAGE_PHP5_MOD_PCRE
        prompt "...-mod-pcre - PCRE module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBPCRE
 
 config BR2_PACKAGE_PHP5_MOD_PGSQL
        prompt "...-mod-pgsql - PostgreSQL module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBPQ
 
 config BR2_PACKAGE_PHP5_MOD_SESSION
        prompt "...-mod-session - Sessions module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
 
 config BR2_PACKAGE_PHP5_MOD_SQLITE
        prompt "...-mod-sqlite - SQLite module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBSQLITE2
 
 config BR2_PACKAGE_PHP5_MOD_SOCKETS
        prompt "...-mod-sockets - Sockets module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
 
 config BR2_PACKAGE_PHP5_MOD_XML
        prompt "...-mod-xml - XML module"
        tristate 
-#      default m if CONFIG_DEVEL
+       default m if CONFIG_DEVEL
        depends BR2_COMPILE_PHP5
        select BR2_PACKAGE_LIBEXPAT
 
index 8879a47..db863ae 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=5.0.4
+PKG_VERSION:=5.0.5
 PKG_RELEASE:=1
-PKG_MD5SUM:=fb1aac107870f897d26563a9cc5053c0
+PKG_MD5SUM:=b5d4ca75bbb11ee5b830fa67213d9f7f
 
 PKG_SOURCE_URL:=http://fr.php.net/distributions/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -59,13 +59,29 @@ PKG_CONFIGURE_OPTS:= \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr" \
 
+ifneq ($(BR2_PACKAGE_PHP5_MOD_CURL),)
+PKG_CONFIGURE_OPTS+= --with-curl=shared,"$(STAGING_DIR)/usr"
+else
+PKG_CONFIGURE_OPTS+= --without-curl
+endif
 ifneq ($(BR2_PACKAGE_PHP5_MOD_GD),)
 PKG_CONFIGURE_OPTS+= --with-gd=shared,"$(STAGING_DIR)/usr" \
+       --without-freetype-dir \
+       --without-jpeg-dir \
+       --with-png-dir="$(STAGING_DIR)/usr" \
+       --without-xpm-dir \
+       --without-ttf \
+       --without-t1lib \
        --enable-gd-native-ttf \
-       --with-png-dir="$(STAGING_DIR)/usr"
+       --disable-gd-jis-conv
 else
 PKG_CONFIGURE_OPTS+= --without-gd
 endif
+ifneq ($(BR2_PACKAGE_PHP5_MOD_GMP),)
+PKG_CONFIGURE_OPTS+= --with-gmp=shared,"$(STAGING_DIR)/usr"
+else
+PKG_CONFIGURE_OPTS+= --without-gmp
+endif
 ifneq ($(BR2_PACKAGE_PHP5_MOD_LDAP),)
 PKG_CONFIGURE_OPTS+= --with-ldap=shared,"$(STAGING_DIR)/usr" \
        --with-ldap-sasl="$(STAGING_DIR)/usr"
@@ -103,8 +119,10 @@ $(eval $(call PKG_template,PHP5_CLI,php5-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(eval $(call PKG_template,PHP5_CGI,php5-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_FASTCGI,php5-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+$(eval $(call PKG_template,PHP5_MOD_CURL,php5-mod-curl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_FTP,php5-mod-ftp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_GD,php5-mod-gd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,PHP5_MOD_GMP,php5-mod-gmp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_LDAP,php5-mod-ldap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_MYSQL,php5-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_OPENSSL,php5-mod-openssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -115,8 +133,10 @@ $(eval $(call PKG_template,PHP5_MOD_SOCKETS,php5-mod-sockets,$(PKG_VERSION)-$(PK
 $(eval $(call PKG_template,PHP5_MOD_SQLITE,php5-mod-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP5_MOD_XML,php5-mod-xml,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+$(eval $(call PKG_mod_template,PHP5_MOD_CURL,curl))
 $(eval $(call PKG_mod_template,PHP5_MOD_FTP,ftp))
 $(eval $(call PKG_mod_template,PHP5_MOD_GD,gd))
+$(eval $(call PKG_mod_template,PHP5_MOD_GMP,gmp))
 $(eval $(call PKG_mod_template,PHP5_MOD_LDAP,ldap))
 $(eval $(call PKG_mod_template,PHP5_MOD_MYSQL,mysql))
 $(eval $(call PKG_mod_template,PHP5_MOD_OPENSSL,openssl))
diff --git a/openwrt/package/php5/ipkg/php5-mod-curl.control b/openwrt/package/php5/ipkg/php5-mod-curl.control
new file mode 100644 (file)
index 0000000..50b7f01
--- /dev/null
@@ -0,0 +1,9 @@
+Package: php5-mod-curl
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Anael Orlinski <anael.orlinski@gmail.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/php4/
+Depends: php5, libcurl
+Description: cURL module for PHP5
diff --git a/openwrt/package/php5/ipkg/php5-mod-gmp.control b/openwrt/package/php5/ipkg/php5-mod-gmp.control
new file mode 100644 (file)
index 0000000..2e2dcd9
--- /dev/null
@@ -0,0 +1,9 @@
+Package: php5-mod-gmp
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Anael Orlinski <anael.orlinski@gmail.com>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/php4/
+Depends: php5, libgmp
+Description: GMP (GNU MP) module for PHP5