netifd: ensure that a bridge gets created before hostapd needs it, hostapd must not...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Nov 2011 01:05:12 +0000 (01:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Nov 2011 01:05:12 +0000 (01:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28745 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files-network/files/lib/network/config.sh
package/base-files/files/sbin/wifi
package/netifd/Makefile
package/netifd/files/lib/network/config.sh

index 29d021a..74810e4 100755 (executable)
@@ -145,6 +145,10 @@ sort_list() {
        ) | sort -u
 }
 
+prepare_interface_bridge() {
+       return 0
+}
+
 # Create the interface, if necessary.
 # Return status 0 indicates that the setup_interface() call should continue
 # Return status 1 means that everything is set up already.
index e2dd0a3..2e66bfc 100755 (executable)
@@ -40,6 +40,7 @@ bridge_interface() {(
 
        config_get iftype "$cfg" type
        [ "$iftype" = bridge ] && config_get "$cfg" ifname
+       prepare_interface_bridge "$cfg"
 )}
 
 prepare_key_wep() {
index 465acd4..98b4a40 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2011-11-03
+PKG_VERSION:=2011-11-04
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=5c0c0bb557b17c581d4f238c52b0b44ada34a608
+PKG_SOURCE_VERSION:=b6d7a8bc9822667cb851bec465c3ad7cd6714e90
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 # PKG_MIRROR_MD5SUM:=
 # CMAKE_INSTALL:=1
index 778c964..4ce362e 100755 (executable)
@@ -40,6 +40,13 @@ scan_interfaces() {
        config_foreach fixup_interface interface
 }
 
+prepare_interface_bridge() {
+       local config="$1"
+
+       [ -n "$config" ] || return 0
+       ubus call network.interface."$config" prepare
+}
+
 setup_interface() {
        local iface="$1"
        local config="$2"