package: kernel/modules: package module for MAC-VLAN support
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 31 Dec 2009 14:33:31 +0000 (14:33 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 31 Dec 2009 14:33:31 +0000 (14:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18980 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netdevices.mk

index 1701fa2..b283855 100644 (file)
@@ -359,3 +359,19 @@ endef
 
 $(eval $(call KernelPackage,gigaset))
 
+
+define KernelPackage/macvlan
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=MAC-VLAN support
+  DEPENDS:=@LINUX_2_6 @!LINUX_2_6_21
+  KCONFIG:=CONFIG_MACVLAN
+  FILES:=$(LINUX_DIR)/drivers/net/macvlan.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,macvlan)
+endef
+
+define KernelPackage/macvlan/description
+ A kernel module which allows one to create virtual interfaces that
+ map packets to or from specific MAC addresses to a particular interface.
+endef
+
+$(eval $(call KernelPackage,macvlan))