iwinfo: add SR71-15 radio info, fix nl80211 channel/frequency reporting on some archi...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Apr 2013 14:44:20 +0000 (14:44 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Apr 2013 14:44:20 +0000 (14:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36417 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_lib.c
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index 8b103eb..d650c0d 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=41
+PKG_RELEASE:=42
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index e943546..368f0cf 100644 (file)
@@ -361,8 +361,9 @@ const struct iwinfo_hardware_entry IWINFO_HARDWARE_ENTRIES[] = {
        { VENDOR_UBNT, "SR4C",                  0x168c, 0x0013, 0x7777, 0x1004,  6,     0 },
        { VENDOR_UBNT, "SR5",                   0x168c, 0x0013, 0x168c, 0x2042,  7,     0 },
        { VENDOR_UBNT, "SR9",                   0x168c, 0x0013, 0x7777, 0x2009, 12, -1500 },
-       { VENDOR_UBNT, "SR71A",                 0x168c, 0x0027, 0x168c, 0x2082, 10,     0 },
-       { VENDOR_UBNT, "SR71",                  0x168c, 0x0027, 0x0777, 0x4082, 10,     0 },
+       { VENDOR_UBNT, "SR71A",                 0x168c, 0x0027, 0x168c, 0x2082,  7,     0 },
+       { VENDOR_UBNT, "SR71",                  0x168c, 0x0027, 0x0777, 0x4082,  7,     0 },
+       { VENDOR_UBNT, "SR71-15",               0x168c, 0x0029, 0x0777, 0x4005,  7,     0 },
 #endif
 #ifdef USE_NL80211
        { VENDOR_UBNT, "PicoStation M2",        0x168c, 0x002a, 0x0777, 0xe302, 12,     0 }, /* ToDo: confirm offset */
index 2a2bb66..dd619e2 100644 (file)
@@ -944,6 +944,7 @@ static int nl80211_get_frequency_info_cb(struct nl_msg *msg, void *arg)
 
 int nl80211_get_frequency(const char *ifname, int *buf)
 {
+       int chn;
        char *res, *channel;
        struct nl80211_msg_conveyor *req;
 
@@ -963,8 +964,8 @@ int nl80211_get_frequency(const char *ifname, int *buf)
            (res = nl80211_hostapd_info(ifname)) &&
            (channel = nl80211_getval(NULL, res, "channel")))
        {
-               *buf = nl80211_channel2freq(atoi(channel),
-                                           nl80211_getval(NULL, res, "hw_mode"));
+               chn = atoi(channel);
+               *buf = nl80211_channel2freq(chn, nl80211_getval(NULL, res, "hw_mode"));
        }
        else
        {