resync patches for 2.6.30-rc3
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Apr 2009 20:46:49 +0000 (20:46 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Apr 2009 20:46:49 +0000 (20:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15494 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
target/linux/generic-2.6/patches-2.6.30/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
target/linux/generic-2.6/patches-2.6.30/600-phy_extension.patch
target/linux/generic-2.6/patches-2.6.30/680-phy_ar8216.patch
target/linux/generic-2.6/patches-2.6.30/840-unable_to_open_console.patch
target/linux/generic-2.6/patches-2.6.30/922-gpiommc.patch
target/linux/generic-2.6/patches-2.6.30/980-vm_exports.patch

index 91dd68b..05fd5fb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -561,6 +561,9 @@ endif
+@@ -566,6 +566,9 @@ endif
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)
  
index 634d222..5760b8e 100644 (file)
        select CRC32
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -151,6 +151,7 @@ obj-$(CONFIG_SLHC) += slhc.o
+@@ -152,6 +152,7 @@ obj-$(CONFIG_SLHC) += slhc.o
  obj-$(CONFIG_XEN_NETDEV_FRONTEND) += xen-netfront.o
  
  obj-$(CONFIG_DUMMY) += dummy.o
index 6077906..139d997 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/input/misc/Kconfig
 +++ b/drivers/input/misc/Kconfig
-@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
-        Say Y to include support for delivering  PMU events via  input
-        layer on NXP PCF50633.
+@@ -250,4 +250,20 @@ config INPUT_RB532_BUTTON
+         To compile this driver as a module, choose M here: the
+         module will be called rb532_button.
  
 +config INPUT_GPIO_BUTTONS
 +      tristate "Polled GPIO buttons interface"
@@ -23,8 +23,8 @@
  endif
 --- a/drivers/input/misc/Makefile
 +++ b/drivers/input/misc/Makefile
-@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT)           += uinput.o
- obj-$(CONFIG_INPUT_APANEL)            += apanel.o
- obj-$(CONFIG_INPUT_SGI_BTNS)          += sgi_btns.o
- obj-$(CONFIG_INPUT_PCF50633_PMU)      += pcf50633-input.o
+@@ -24,3 +24,4 @@ obj-$(CONFIG_INPUT_SPARCSPKR)                += sparcs
+ obj-$(CONFIG_INPUT_UINPUT)            += uinput.o
+ obj-$(CONFIG_INPUT_WISTRON_BTNS)      += wistron_btns.o
+ obj-$(CONFIG_INPUT_YEALINK)           += yealink.o
 +obj-$(CONFIG_INPUT_GPIO_BUTTONS)      += gpio_buttons.o
index 990d3cd..72a4fa5 100644 (file)
@@ -73,7 +73,7 @@
        idx = phy_find_valid(idx, phydev->supported);
 --- a/include/linux/phy.h
 +++ b/include/linux/phy.h
-@@ -477,6 +477,7 @@ void phy_start_machine(struct phy_device
+@@ -483,6 +483,7 @@ void phy_start_machine(struct phy_device
  void phy_stop_machine(struct phy_device *phydev);
  int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
  int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
index 2e9bab1..6cb3fd4 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -84,6 +84,10 @@ config IP175C_PHY
-       tristate "Driver for IC+ IP175C/IP178C switches"
-       select SWCONFIG
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
  
 +config AR8216_PHY
 +      tristate "Driver for Atheros AR8216 switches"
@@ -16,8 +16,8 @@
 @@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY)     += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
- obj-$(CONFIG_IP175C_PHY)      += ip175c.o
-+obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
++obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
  obj-$(CONFIG_MDIO_BITBANG)    += mdio-bitbang.o
index 8d90396..c9a2774 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -807,7 +807,7 @@ static noinline int init_post(void)
+@@ -812,7 +812,7 @@ static noinline int init_post(void)
        numa_default_policy();
  
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index 1d49b12..dbfa823 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -1997,6 +1997,11 @@ L:      linux-media@vger.kernel.org
- T:    git kernel.org:/pub/scm/linux/kernel/git/mchehab/linux-2.6.git
+@@ -2490,6 +2490,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
+ F:    drivers/media/video/gspca/
  
 +GPIOMMC DRIVER
 +P:    Michael Buesch
index ca2f052..6777383 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/shmem.c
 +++ b/mm/shmem.c
-@@ -2587,6 +2587,16 @@ int shmem_unuse(swp_entry_t entry, struc
+@@ -2602,6 +2602,16 @@ int shmem_unuse(swp_entry_t entry, struc
  
  /* common code */
  
@@ -17,7 +17,7 @@
  /**
   * shmem_file_setup - get an unlinked file living in tmpfs
   * @name: name for dentry (to be seen in /proc/<pid>/maps
-@@ -2665,11 +2675,7 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -2680,11 +2690,7 @@ int shmem_zero_setup(struct vm_area_stru
        if (IS_ERR(file))
                return PTR_ERR(file);
  
@@ -70,7 +70,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -5600,6 +5600,7 @@ int can_nice(const struct task_struct *p
+@@ -5665,6 +5665,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }