more fixes
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 23:04:46 +0000 (23:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 23:04:46 +0000 (23:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5048 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-build.mk
rules.mk

index 6aefe0b..5544a82 100644 (file)
@@ -4,6 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+include $(INCLUDE_DIR)/host.mk
 -include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
 -include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
index b9859db..be269e7 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -84,6 +84,7 @@ RSTRIP:= \
 
 # where to build (and put) .ipk packages
 IPKG:= \
 
 # where to build (and put) .ipk packages
 IPKG:= \
+  PATH="$(STAGING_DIR)/bin:$(PATH)" \
   IPKG_TMP=$(BUILD_DIR)/tmp \
   IPKG_INSTROOT=$(TARGET_DIR) \
   IPKG_CONF_DIR=$(STAGING_DIR)/etc \
   IPKG_TMP=$(BUILD_DIR)/tmp \
   IPKG_INSTROOT=$(TARGET_DIR) \
   IPKG_CONF_DIR=$(STAGING_DIR)/etc \