Fix build for individual profiles with dashes in names
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jan 2014 12:27:32 +0000 (12:27 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jan 2014 12:27:32 +0000 (12:27 +0000)
Config symbols can have regular dashes, e.g.

CONFIG_TARGET_ramips_rt305x_UR-336UN=y

So no substitution should be performed on the last part of the symbol.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39242 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index eca218e..ccec41f 100644 (file)
@@ -76,7 +76,7 @@ define Profile
        $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
-  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
+  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
     PROFILE=$(1)
   endif
 endef