kernel: gsc depends on kmod-i2c-core
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Sep 2013 23:38:54 +0000 (23:38 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Sep 2013 23:38:54 +0000 (23:38 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37960 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index b1f4744..54e9b18 100644 (file)
@@ -211,7 +211,7 @@ define KernelPackage/hwmon-w83627hf
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
+  $(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description
@@ -225,8 +225,8 @@ define KernelPackage/hwmon-gsc
   TITLE:=Gateworks GSC monitoring support
   KCONFIG:=CONFIG_SENSORS_GSC
   FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
-  AUTOLOAD:=$(call AutoLoad,50,gsc)
-$(call AddDepends/hwmon)
+  AUTOLOAD:=$(call AutoLoad,60,gsc)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPacakge/hwmon-gsc/description