[lantiq] add support for arv7525
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Nov 2012 07:38:24 +0000 (07:38 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Nov 2012 07:38:24 +0000 (07:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34097 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/profiles/001-lantiq.mk

index de5365e..11374ef 100644 (file)
@@ -207,6 +207,9 @@ Image/Build/Profile/EASY80920-NAND=$(call Image/Build/$(1),$(1),EASY80920-NAND)
 Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
 Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
 
 Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
 Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
 
+Image/BuildKernel/Profile/ARV7525PW=$(call Image/BuildKernel/Template,ARV7525PW)
+Image/Build/Profile/ARV7525PW=$(call Image/Build/$(1),$(1),ARV7525PW)
+
 endif
 
 ifeq ($(CONFIG_TARGET_lantiq_vr9),y)
 endif
 
 ifeq ($(CONFIG_TARGET_lantiq_vr9),y)
index 2c24d3c..6243568 100644 (file)
@@ -17,3 +17,13 @@ define Profile/EASY80920-NAND/Description
 endef
 
 $(eval $(call Profile,EASY80920-NAND))
 endef
 
 $(eval $(call Profile,EASY80920-NAND))
+
+define Profile/ARV7525PW
+  NAME:=ARV7525PW
+endef
+
+define Profile/ARV7525PW/Description
+       Speedport W303V - ARV7525PW
+endef
+
+$(eval $(call Profile,ARV7525PW))