imagebuilder: merge r25078 to align files/ handling with current buildroot
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Nov 2012 19:46:54 +0000 (19:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Nov 2012 19:46:54 +0000 (19:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34301 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/files/Makefile

index b0d0698..4d0f1fe 100644 (file)
@@ -134,6 +134,14 @@ package_install: FORCE
 copy_files: FORCE
        @echo
        @echo Copying extra files
+       @( cd $(USER_FILES); find -type f ) | \
+               ( cd $(TARGET_DIR); while :; do \
+                       read FILE; \
+                       [ -z "$$FILE" ] && break; \
+                       [ -L "$$FILE" ] || continue; \
+                       echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+                       rm -f "$$FILE"; \
+               done; )
        $(CP) $(USER_FILES)/* $(TARGET_DIR)/
 
 package_postinst: FORCE