openssl: refresh patches
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jan 2010 19:27:53 +0000 (19:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Jan 2010 19:27:53 +0000 (19:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19368 3c298f89-4303-0410-b956-a3cf2f4a3e73

17 files changed:
package/openssl/patches/100-parallel-build.patch
package/openssl/patches/110-optimize-for-size.patch
package/openssl/patches/120-makedepend.patch
package/openssl/patches/121-ocf-config.patch
package/openssl/patches/130-perl-path.patch
package/openssl/patches/140-makefile-dirs.patch
package/openssl/patches/150-no_engines.patch
package/openssl/patches/160-disable_doc_tests.patch
package/openssl/patches/169-makefile-ccache_needs_quotes.patch
package/openssl/patches/170-bash_path.patch
package/openssl/patches/200-ocf-20080917.patch
package/openssl/patches/300-etrax_support.patch
package/openssl/patches/310-arm_asm.patch
package/openssl/patches/900-CVE-2009-1377.patch
package/openssl/patches/900-CVE-2009-1378.patch
package/openssl/patches/900-CVE-2009-1379.patch
package/openssl/patches/901-remove_rej.patch

index eace0f4..0e07ba4 100644 (file)
@@ -1,7 +1,6 @@
-diff -uNr openssl-0.9.8j.ORIG/Makefile.org openssl-0.9.8j/Makefile.org
---- openssl-0.9.8j.ORIG/Makefile.org   2009-01-07 18:06:31.000000000 +0000
-+++ openssl-0.9.8j/Makefile.org        2009-01-07 18:08:38.000000000 +0000
-@@ -333,15 +333,15 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -333,15 +333,15 @@ build_crypto:
                dir=crypto; target=all; $(BUILD_ONE_CMD)
  build_fips:
        @dir=fips; target=all; [ -z "$(FIPSCANLIB)" ] || $(BUILD_ONE_CMD)
index ddd2ea6..7661a8d 100644 (file)
@@ -1,7 +1,6 @@
-diff -ur openssl-0.9.8h.orig/Configure openssl-0.9.8h/Configure
---- openssl-0.9.8h.orig/Configure      2008-05-31 17:27:47.000000000 +0200
-+++ openssl-0.9.8h/Configure   2008-05-31 17:28:16.000000000 +0200
-@@ -357,6 +357,8 @@
+--- a/Configure
++++ b/Configure
+@@ -364,6 +364,8 @@ my %table=(
  "linux-alpha+bwx-gcc","gcc:-O3 -DL_ENDIAN -DTERMIO::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_RISC1 DES_UNROLL:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
  "linux-alpha-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${no_asm}",
  "linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${no_asm}",
index 01af569..228e112 100644 (file)
@@ -1,7 +1,6 @@
-diff -burN openssl-0.9.8k/util/domd openssl-0.9.8k.patched/util/domd
---- openssl-0.9.8k/util/domd   2009-01-21 22:44:52.000000000 +0100
-+++ openssl-0.9.8k.patched/util/domd   2009-03-26 15:46:28.600347986 +0100
-@@ -14,7 +14,8 @@
+--- a/util/domd
++++ b/util/domd
+@@ -14,7 +14,8 @@ if [ "$MAKEDEPEND" = "" ]; then MAKEDEPE
  cp Makefile Makefile.save
  # fake the presence of Kerberos
  touch $TOP/krb5.h
@@ -11,7 +10,7 @@ diff -burN openssl-0.9.8k/util/domd openssl-0.9.8k.patched/util/domd
      args=""
      while [ $# -gt 0 ]; do
        if [ "$1" != "--" ]; then args="$args $1"; fi
-@@ -22,7 +23,7 @@
+@@ -22,7 +23,7 @@ if [ "$MAKEDEPEND" = "gcc" ]; then
      done
      sed -e '/^# DO NOT DELETE.*/,$d' < Makefile > Makefile.tmp
      echo '# DO NOT DELETE THIS LINE -- make depend depends on it.' >> Makefile.tmp
index 1656be8..d40f1ee 100644 (file)
@@ -1,7 +1,6 @@
-diff -burN openssl-0.9.8k/config openssl-0.9.8k.patched/config
---- openssl-0.9.8k/config      2009-02-16 09:43:41.000000000 +0100
-+++ openssl-0.9.8k.patched/config      2009-03-27 19:38:37.262255825 +0100
-@@ -399,8 +399,11 @@
+--- a/config
++++ b/config
+@@ -399,8 +399,11 @@ exit 0
  # this is where the translation occurs into SSLeay terms
  # ---------------------------------------------------------------------------
  
@@ -13,7 +12,7 @@ diff -burN openssl-0.9.8k/config openssl-0.9.8k.patched/config
    # then strip off whatever prefix egcs prepends the number with...
    # Hopefully, this will work for any future prefixes as well.
    GCCVER=`echo $GCCVER | LC_ALL=C sed 's/^[a-zA-Z]*\-//'`
-@@ -409,6 +412,8 @@
+@@ -409,6 +412,8 @@ if [ "$GCCVER" != "" ]; then
    # major and minor version numbers.
    # peak single digit before and after first dot, e.g. 2.95.1 gives 29
    GCCVER=`echo $GCCVER | sed 's/\([0-9]\)\.\([0-9]\).*/\1\2/'`
index 3edc796..d5722b2 100644 (file)
@@ -1,77 +1,61 @@
-Index: openssl-0.9.8e/Configure
-===================================================================
---- openssl-0.9.8e.orig/Configure      2007-06-04 13:23:32.217836040 +0200
-+++ openssl-0.9.8e/Configure   2007-06-04 13:23:32.598778128 +0200
+--- a/Configure
++++ b/Configure
 @@ -1,4 +1,4 @@
 -:
 +#!/usr/bin/perl
  eval 'exec perl -S $0 ${1+"$@"}'
      if $running_under_some_shell;
  ##
-Index: openssl-0.9.8e/tools/c_rehash.in
-===================================================================
---- openssl-0.9.8e.orig/tools/c_rehash.in      2007-06-04 13:23:32.074857776 +0200
-+++ openssl-0.9.8e/tools/c_rehash.in   2007-06-04 13:23:32.598778128 +0200
+--- a/tools/c_rehash.in
++++ b/tools/c_rehash.in
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl
 +#!/usr/bin/perl
  
  
  # Perl c_rehash script, scan all files in a directory
-Index: openssl-0.9.8e/util/clean-depend.pl
-===================================================================
---- openssl-0.9.8e.orig/util/clean-depend.pl   2007-06-04 13:23:32.080856864 +0200
-+++ openssl-0.9.8e/util/clean-depend.pl        2007-06-04 13:23:32.598778128 +0200
+--- a/util/clean-depend.pl
++++ b/util/clean-depend.pl
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl -w
 +#!/usr/bin/perl -w
  # Clean the dependency list in a makefile of standard includes...
  # Written by Ben Laurie <ben@algroup.co.uk> 19 Jan 1999
  
-Index: openssl-0.9.8e/util/mkdef.pl
-===================================================================
---- openssl-0.9.8e.orig/util/mkdef.pl  2007-06-04 13:23:32.085856104 +0200
-+++ openssl-0.9.8e/util/mkdef.pl       2007-06-04 13:23:32.599777976 +0200
+--- a/util/mkdef.pl
++++ b/util/mkdef.pl
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl -w
 +#!/usr/bin/perl
  #
  # generate a .def file
  #
-Index: openssl-0.9.8e/util/mkerr.pl
-===================================================================
---- openssl-0.9.8e.orig/util/mkerr.pl  2007-06-04 13:23:32.091855192 +0200
-+++ openssl-0.9.8e/util/mkerr.pl       2007-06-04 13:23:32.599777976 +0200
+--- a/util/mkerr.pl
++++ b/util/mkerr.pl
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl -w
 +#!/usr/bin/perl
  
  my $config = "crypto/err/openssl.ec";
  my $debug = 0;
-Index: openssl-0.9.8e/util/mkstack.pl
-===================================================================
---- openssl-0.9.8e.orig/util/mkstack.pl        2007-06-04 13:23:32.096854432 +0200
-+++ openssl-0.9.8e/util/mkstack.pl     2007-06-04 13:23:32.600777824 +0200
+--- a/util/mkstack.pl
++++ b/util/mkstack.pl
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl -w
 +#!/usr/bin/perl
  
  # This is a utility that searches out "DECLARE_STACK_OF()"
  # declarations in .h and .c files, and updates/creates/replaces
-Index: openssl-0.9.8e/util/pod2man.pl
-===================================================================
---- openssl-0.9.8e.orig/util/pod2man.pl        2007-06-04 13:23:32.102853520 +0200
-+++ openssl-0.9.8e/util/pod2man.pl     2007-06-04 13:23:32.600777824 +0200
+--- a/util/pod2man.pl
++++ b/util/pod2man.pl
 @@ -1,4 +1,4 @@
 -: #!/usr/bin/perl-5.005
 +#!/usr/bin/perl
      eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
        if $running_under_some_shell;
  
-Index: openssl-0.9.8e/util/selftest.pl
-===================================================================
---- openssl-0.9.8e.orig/util/selftest.pl       2007-06-04 13:23:32.109852456 +0200
-+++ openssl-0.9.8e/util/selftest.pl    2007-06-04 13:23:32.600777824 +0200
+--- a/util/selftest.pl
++++ b/util/selftest.pl
 @@ -1,4 +1,4 @@
 -#!/usr/local/bin/perl -w
 +#!/usr/bin/perl
index d0eaec9..9979782 100644 (file)
@@ -1,6 +1,6 @@
---- openssl-0.9.8j/Makefile.org        2008-12-30 14:26:26.000000000 +0100
-+++ openssl-0.9.8j.patched/Makefile.org        2009-01-17 13:41:52.610868317 +0100
-@@ -131,7 +131,7 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -131,7 +131,7 @@ FIPSCANLIB=
  
  BASEADDR=
  
index 127ce98..e344b49 100644 (file)
@@ -1,7 +1,6 @@
-diff -ur openssl-0.9.8i.orig/Configure openssl-0.9.8i/Configure
---- openssl-0.9.8i.orig/Configure      2008-05-31 17:31:04.000000000 +0200
-+++ openssl-0.9.8i/Configure   2008-05-31 17:30:47.000000000 +0200
-@@ -1714,6 +1714,11 @@
+--- a/Configure
++++ b/Configure
+@@ -1850,6 +1850,11 @@ EOF
        close(OUT);
    }
    
@@ -13,10 +12,9 @@ diff -ur openssl-0.9.8i.orig/Configure openssl-0.9.8i/Configure
  print <<EOF;
  
  Configured for $target.
-diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
---- openssl-0.9.8i.orig/util/libeay.num        2008-05-31 17:27:46.000000000 +0200
-+++ openssl-0.9.8i/util/libeay.num     2008-05-31 17:30:47.000000000 +0200
-@@ -2071,7 +2071,6 @@
+--- a/util/libeay.num
++++ b/util/libeay.num
+@@ -2071,7 +2071,6 @@ PKCS7_ATTR_SIGN_it                      
  UI_add_error_string                     2633  EXIST::FUNCTION:
  KRB5_CHECKSUM_free                      2634  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext                    2635  EXIST::FUNCTION:
@@ -24,7 +22,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  ENGINE_register_all_digests             2637  EXIST::FUNCTION:ENGINE
  PKEY_USAGE_PERIOD_it                    2638  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  PKEY_USAGE_PERIOD_it                    2638  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-@@ -2545,7 +2544,6 @@
+@@ -2545,7 +2544,6 @@ OCSP_RESPONSE_new                       
  AES_set_encrypt_key                     3024  EXIST::FUNCTION:AES
  OCSP_resp_count                         3025  EXIST::FUNCTION:
  KRB5_CHECKSUM_new                       3026  EXIST::FUNCTION:
@@ -32,7 +30,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  OCSP_onereq_get0_id                     3028  EXIST::FUNCTION:
  ENGINE_set_default_ciphers              3029  EXIST::FUNCTION:ENGINE
  NOTICEREF_it                            3030  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
-@@ -2576,7 +2574,6 @@
+@@ -2576,7 +2574,6 @@ ASN1_primitive_free                     
  i2d_EXTENDED_KEY_USAGE                  3052  EXIST::FUNCTION:
  i2d_OCSP_SIGNATURE                      3053  EXIST::FUNCTION:
  asn1_enc_save                           3054  EXIST::FUNCTION:
@@ -40,7 +38,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  _ossl_old_des_pcbc_encrypt              3056  EXIST::FUNCTION:DES
  PKCS12_MAC_DATA_it                      3057  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  PKCS12_MAC_DATA_it                      3057  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
-@@ -2600,7 +2597,6 @@
+@@ -2600,7 +2597,6 @@ asn1_get_choice_selector                
  i2d_KRB5_CHECKSUM                       3072  EXIST::FUNCTION:
  ENGINE_set_table_flags                  3073  EXIST::FUNCTION:ENGINE
  AES_options                             3074  EXIST::FUNCTION:AES
@@ -48,7 +46,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  OCSP_id_cmp                             3076  EXIST::FUNCTION:
  OCSP_BASICRESP_new                      3077  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext_by_NID             3078  EXIST::FUNCTION:
-@@ -2667,7 +2663,6 @@
+@@ -2667,7 +2663,6 @@ OCSP_CRLID_it                           
  OCSP_CRLID_it                           3127  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
  i2d_KRB5_AUTHENTBODY                    3128  EXIST::FUNCTION:
  OCSP_REQUEST_get_ext_count              3129  EXIST::FUNCTION:
@@ -56,7 +54,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  X509_NAME_it                            3131  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
  X509_NAME_it                            3131  EXIST:EXPORT_VAR_AS_FUNCTION:FUNCTION:
  USERNOTICE_it                           3132  EXIST:!EXPORT_VAR_AS_FUNCTION:VARIABLE:
-@@ -2762,8 +2757,6 @@
+@@ -2762,8 +2757,6 @@ DES_read_2passwords                     
  DES_read_password                       3207  EXIST::FUNCTION:DES
  UI_UTIL_read_pw                         3208  EXIST::FUNCTION:
  UI_UTIL_read_pw_string                  3209  EXIST::FUNCTION:
@@ -65,7 +63,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  OPENSSL_add_all_algorithms_noconf       3212  EXIST:!VMS:FUNCTION:
  OPENSSL_add_all_algo_noconf             3212  EXIST:VMS:FUNCTION:
  OPENSSL_add_all_algorithms_conf         3213  EXIST:!VMS:FUNCTION:
-@@ -2772,7 +2765,6 @@
+@@ -2772,7 +2765,6 @@ OPENSSL_load_builtin_modules            
  AES_ofb128_encrypt                      3215  EXIST::FUNCTION:AES
  AES_ctr128_encrypt                      3216  EXIST::FUNCTION:AES
  AES_cfb128_encrypt                      3217  EXIST::FUNCTION:AES
@@ -73,7 +71,7 @@ diff -ur openssl-0.9.8i.orig/util/libeay.num openssl-0.9.8i/util/libeay.num
  _ossl_096_des_random_seed               3219  EXIST::FUNCTION:DES
  EVP_aes_256_ofb                         3220  EXIST::FUNCTION:AES
  EVP_aes_192_ofb                         3221  EXIST::FUNCTION:AES
-@@ -3107,7 +3099,6 @@
+@@ -3107,7 +3099,6 @@ EC_GFp_nist_method                      
  STORE_method_set_modify_function        3530  EXIST:!VMS:FUNCTION:
  STORE_meth_set_modify_fn                3530  EXIST:VMS:FUNCTION:
  STORE_parse_attrs_next                  3531  EXIST::FUNCTION:
index e64a919..32a6d29 100644 (file)
@@ -1,7 +1,6 @@
-diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
---- openssl-0.9.8k/Makefile    2009-03-25 14:11:43.000000000 +0100
-+++ openssl-0.9.8k.patched/Makefile    2009-03-26 15:28:35.483566078 +0100
-@@ -133,7 +133,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -133,7 +133,7 @@ FIPSCANLIB=
  
  BASEADDR=0xFB00000
  
@@ -10,7 +9,7 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  SHLIBDIRS= crypto ssl
  
  # dirs in crypto to build
-@@ -150,7 +150,7 @@
+@@ -150,7 +150,7 @@ SDIRS=  \
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
@@ -19,7 +18,7 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  
  MAKEFILE= Makefile
  
-@@ -162,7 +162,7 @@
+@@ -162,7 +162,7 @@ SHELL=/bin/sh
  
  TOP=    .
  ONEDIRS=out tmp
@@ -28,7 +27,7 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
  SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
-@@ -321,7 +321,7 @@
+@@ -321,7 +321,7 @@ FIPS_EX_OBJ= ../crypto/aes/aes_cfb.o \
        ../crypto/uid.o
  
  sub_all: build_all
@@ -37,7 +36,7 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  
  build_libs: build_crypto build_fips build_ssl build_shared build_engines
  
-@@ -613,7 +613,7 @@
+@@ -613,7 +613,7 @@ dist:   
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -46,10 +45,9 @@ diff -burN openssl-0.9.8k/Makefile openssl-0.9.8k.patched/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-diff -burN openssl-0.9.8k/Makefile.org openssl-0.9.8k.patched/Makefile.org
---- openssl-0.9.8k/Makefile.org        2009-03-03 23:40:29.000000000 +0100
-+++ openssl-0.9.8k.patched/Makefile.org        2009-03-26 15:29:05.243750064 +0100
-@@ -611,7 +611,7 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -611,7 +611,7 @@ dist:   
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
index 70a0eec..94b3b78 100644 (file)
@@ -1,6 +1,6 @@
---- openssl-0.9.8k/Makefile.org        2009-04-06 13:52:21.000000000 +0200
-+++ openssl-0.9.8k.patched/Makefile.org        2009-04-06 13:54:04.000000000 +0200
-@@ -357,7 +357,7 @@
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -357,7 +357,7 @@ libcrypto$(SHLIB_EXT): libcrypto.a $(SHA
                        $(AR) libcrypto.a fips/fipscanister.o ; \
                else \
                        if [ "$(FIPSCANLIB)" = "libcrypto" ]; then \
@@ -9,7 +9,7 @@
                                export CC FIPSLD_CC; \
                        fi; \
                        $(MAKE) -e SHLIBDIRS='crypto' build-shared; \
-@@ -380,7 +380,7 @@
+@@ -380,7 +380,7 @@ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT
  fips/fipscanister.o:  build_fips
  libfips$(SHLIB_EXT):          fips/fipscanister.o
        @if [ "$(SHLIB_TARGET)" != "" ]; then \
@@ -18,9 +18,9 @@
                $(MAKE) -f Makefile.shared -e $(BUILDENV) \
                        CC=$${CC} LIBNAME=fips THIS=$@ \
                        LIBEXTRAS=fips/fipscanister.o \
---- openssl-0.9.8k/apps/Makefile       2009-04-06 22:07:06.000000000 +0200
-+++ openssl-0.9.8k.patched/apps/Makefile       2009-04-06 22:12:39.000000000 +0200
-@@ -153,7 +153,7 @@
+--- a/apps/Makefile
++++ b/apps/Makefile
+@@ -153,12 +153,12 @@ $(EXE): progs.h $(E_OBJ) $(PROGRAM).o $(
        shlib_target=; if [ -n "$(SHARED_LIBS)" ]; then \
                shlib_target="$(SHLIB_TARGET)"; \
        elif [ -n "$(FIPSCANLIB)" ]; then \
@@ -29,9 +29,6 @@
        fi; \
        LIBRARIES="$(LIBSSL) $(LIBKRB5) $(LIBCRYPTO)" ; \
        [ "x$(FIPSCANLIB)" = "xlibfips" ] && LIBRARIES="$$LIBRARIES -lfips"; \
-@@ -158,7 +158,7 @@
-       LIBRARIES="$(LIBSSL) $(LIBKRB5) $(LIBCRYPTO)" ; \
-       [ "x$(FIPSCANLIB)" = "xlibfips" ] && LIBRARIES="$$LIBRARIES -lfips"; \
        $(MAKE) -f $(TOP)/Makefile.shared -e \
 -              CC=$${CC} APPNAME=$(EXE) OBJECTS="$(PROGRAM).o $(E_OBJ)" \
 +              CC="$${CC}" APPNAME=$(EXE) OBJECTS="$(PROGRAM).o $(E_OBJ)" \
index accde6c..c29b59a 100644 (file)
@@ -1,7 +1,5 @@
-Index: openssl-0.9.8e/util/domd
-===================================================================
---- openssl-0.9.8e.orig/util/domd      2007-06-04 13:23:32.408807008 +0200
-+++ openssl-0.9.8e/util/domd   2007-06-04 13:23:33.442649840 +0200
+--- a/util/domd
++++ b/util/domd
 @@ -1,4 +1,4 @@
 -#!/bin/sh
 +#!/usr/bin/env bash
index bf72d8a..6da5644 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Configure
 +++ b/Configure
-@@ -34,6 +34,8 @@ my $usage="Usage: Configure [no-<cipher>
+@@ -36,6 +36,8 @@ my $usage="Usage: Configure [no-<cipher>
  #             (Default: KRB5_DIR/include)
  # --with-krb5-flavor  Declare what flavor of Kerberos 5 is used.  Currently
  #             supported values are "MIT" and "Heimdal".  A value is required.
@@ -9,7 +9,7 @@
  #
  # --test-sanity Make a number of sanity checks on the data in this file.
  #               This is a debugging tool for OpenSSL developers.
-@@ -540,6 +542,9 @@ my %table=(
+@@ -547,6 +549,9 @@ my %table=(
  ##### Compaq Non-Stop Kernel (Tandem)
  "tandem-c89","c89:-Ww -D__TANDEM -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED=1 -D_TANDEM_SOURCE -DB_ENDIAN::(unknown):::THIRTY_TWO_BIT:::",
  
@@ -19,7 +19,7 @@
  );
  
  my @MK1MF_Builds=qw(VC-WIN64I VC-WIN64A
-@@ -589,6 +594,8 @@ my $montasm=1;   # but "no-montasm" is d
+@@ -601,6 +606,8 @@ my $montasm=1;   # but "no-montasm" is d
  my $no_asm=0;
  my $no_dso=0;
  my $no_gmp=0;
@@ -28,7 +28,7 @@
  my @skip=();
  my $Makefile="Makefile";
  my $des_locl="crypto/des/des_locl.h";
-@@ -716,6 +723,14 @@ PROCESS_ARGS:
+@@ -749,6 +756,14 @@ PROCESS_ARGS:
                        {
                        exit(&test_sanity());
                        }
@@ -43,7 +43,7 @@
                elsif (/^reconfigure/ || /^reconf/)
                        {
                        if (open(IN,"<$Makefile"))
-@@ -924,6 +939,7 @@ foreach (sort (keys %disabled))
+@@ -1037,6 +1052,7 @@ foreach (sort (keys %disabled))
                        print " OPENSSL_NO_$ALGO";
                
                        if (/^err$/)    { $flags .= "-DOPENSSL_NO_ERR "; }
@@ -51,7 +51,7 @@
                        elsif (/^asm$/) { $no_asm = 1; }
                        }
                else
-@@ -1064,6 +1080,16 @@ if (!$no_krb5)
+@@ -1161,6 +1177,16 @@ if (!$no_krb5)
                   $withargs{"krb5-dir"} ne "";
        }
  
   ----------------------
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -367,7 +367,7 @@ files:
+@@ -502,7 +502,7 @@ files:
  
  links:
        @$(PERL) $(TOP)/util/mkdir-p.pl include/openssl
 -      @$(PERL) $(TOP)/util/mklink.pl include/openssl $(EXHEADER)
 +      @$(PERL) $(TOP)/util/mklink.pl include/openssl $(HEADER) $(EXHEADER)
        @set -e; target=links; $(RECURSIVE_BUILD_CMD)
- gentests:
+       @if [ -z "$(FIPSCANLIB)" ]; then \
+               set -e; target=links; dir=fips ; $(BUILD_CMD) ; \
 --- a/Makefile.shared
 +++ b/Makefile.shared
 @@ -6,13 +6,13 @@
 -  CC=cc
 +  CC="${CC:-cc}"
  fi
- GCCVER=${GCCVER:-0}
- if [ "$SYSTEM" = "HP-UX" ];then
-@@ -482,6 +482,9 @@ echo Operating system: $GUESSOS
+ # Only set CC if not supplied already
+@@ -493,6 +493,9 @@ echo Operating system: $GUESSOS
  # script above so we end up with values in vars but that would take
  # more time that I want to waste at the moment
  case "$GUESSOS" in
        results[alg][run_no]=((double)count)/time_used*lengths[run_no];
        }
  
-@@ -2806,29 +2928,11 @@ static int do_multi(int multi)
+@@ -2808,29 +2930,11 @@ static int do_multi(int multi)
                                p=buf+3;
                                alg=atoi(sstrsep(&p,sep));
                                sstrsep(&p,sep);
                                }
                        else if(!strncmp(buf,"+F2:",4))
                                {
-@@ -2839,12 +2943,18 @@ static int do_multi(int multi)
+@@ -2841,12 +2945,18 @@ static int do_multi(int multi)
                                k=atoi(sstrsep(&p,sep));
                                sstrsep(&p,sep);
  
                                d=atof(sstrsep(&p,sep));
                                if(n)
                                        rsa_results[k][1]=1/(1/rsa_results[k][1]+1/d);
-@@ -2860,12 +2970,18 @@ static int do_multi(int multi)
+@@ -2862,12 +2972,18 @@ static int do_multi(int multi)
                                k=atoi(sstrsep(&p,sep));
                                sstrsep(&p,sep);
  
index 89b3a92..758ebeb 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN openssl-0.9.8h.orig/Configure openssl-0.9.8h/Configure
---- openssl-0.9.8h.orig/Configure      2008-05-02 01:11:30.000000000 +0200
-+++ openssl-0.9.8h/Configure   2008-06-19 13:27:42.000000000 +0200
-@@ -389,6 +389,10 @@
+--- a/Configure
++++ b/Configure
+@@ -396,6 +396,10 @@ my %table=(
  "qnx4",       "cc:-DL_ENDIAN -DTERMIO::(unknown):::${x86_gcc_des} ${x86_gcc_opts}:",
  "qnx6",       "cc:-DL_ENDIAN -DTERMIOS::(unknown)::-lsocket:${x86_gcc_des} ${x86_gcc_opts}:",
  
index 2d940f0..9b53a22 100644 (file)
@@ -10,4 +10,3 @@
  aes-ia64.s: asm/aes-ia64.S
        $(CC) $(CFLAGS) -E asm/aes-ia64.S > $@
  
-
index cc5a19f..8b8faf4 100644 (file)
@@ -1,11 +1,8 @@
 http://rt.openssl.org/Ticket/Display.html?id=1931&user=guest&pass=guest
 
-Index: openssl/crypto/pqueue/pqueue.c
-RCS File: /v/openssl/cvs/openssl/crypto/pqueue/pqueue.c,v
-rcsdiff -q -kk '-r1.2.2.4' '-r1.2.2.5' -u '/v/openssl/cvs/openssl/crypto/pqueue/pqueue.c,v' 2>/dev/null
---- pqueue.c   2005/06/28 12:53:33     1.2.2.4
-+++ pqueue.c   2009/05/16 16:18:44     1.2.2.5
-@@ -234,3 +234,17 @@
+--- a/crypto/pqueue/pqueue.c
++++ b/crypto/pqueue/pqueue.c
+@@ -234,3 +234,17 @@ pqueue_next(pitem **item)
  
        return ret;
        }
@@ -23,24 +20,18 @@ rcsdiff -q -kk '-r1.2.2.4' '-r1.2.2.5' -u '/v/openssl/cvs/openssl/crypto/pqueue/
 +      }
 +      return count;
 +}
-Index: openssl/crypto/pqueue/pqueue.h
-RCS File: /v/openssl/cvs/openssl/crypto/pqueue/pqueue.h,v
-rcsdiff -q -kk '-r1.2.2.1' '-r1.2.2.2' -u '/v/openssl/cvs/openssl/crypto/pqueue/pqueue.h,v' 2>/dev/null
---- pqueue.h   2005/05/30 22:34:27     1.2.2.1
-+++ pqueue.h   2009/05/16 16:18:44     1.2.2.2
-@@ -91,5 +91,6 @@
+--- a/crypto/pqueue/pqueue.h
++++ b/crypto/pqueue/pqueue.h
+@@ -91,5 +91,6 @@ pitem *pqueue_iterator(pqueue pq);
  pitem *pqueue_next(piterator *iter);
  
  void   pqueue_print(pqueue pq);
 +int    pqueue_size(pqueue pq);
  
  #endif /* ! HEADER_PQUEUE_H */
-Index: openssl/ssl/d1_pkt.c
-RCS File: /v/openssl/cvs/openssl/ssl/d1_pkt.c,v
-rcsdiff -q -kk '-r1.4.2.17' '-r1.4.2.18' -u '/v/openssl/cvs/openssl/ssl/d1_pkt.c,v' 2>/dev/null
---- d1_pkt.c   2009/05/16 15:51:59     1.4.2.17
-+++ d1_pkt.c   2009/05/16 16:18:45     1.4.2.18
-@@ -167,6 +167,10 @@
+--- a/ssl/d1_pkt.c
++++ b/ssl/d1_pkt.c
+@@ -167,6 +167,10 @@ dtls1_buffer_record(SSL *s, record_pqueu
      DTLS1_RECORD_DATA *rdata;
        pitem *item;
  
index 50f51cd..514d444 100644 (file)
@@ -1,9 +1,7 @@
 http://rt.openssl.org/Ticket/Display.html?id=1931&user=guest&pass=guest
 
-Index: openssl/ssl/d1_both.c
-===================================================================
---- d1_both.c.orig
-+++ d1_both.c
+--- a/ssl/d1_both.c
++++ b/ssl/d1_both.c
 @@ -561,7 +561,16 @@ dtls1_process_out_of_seq_message(SSL *s,
        if ((msg_hdr->frag_off+frag_len) > msg_hdr->msg_len)
                goto err;
index 7067324..b72f116 100644 (file)
@@ -1,9 +1,6 @@
-Index: openssl/ssl/d1_both.c
-RCS File: /v/openssl/cvs/openssl/ssl/d1_both.c,v
-rcsdiff -q -kk '-r1.14.2.6' '-r1.14.2.7' -u '/v/openssl/cvs/openssl/ssl/d1_both.c,v' 2>/dev/null
---- d1_both.c  2009/04/22 12:17:02     1.14.2.6
-+++ d1_both.c  2009/05/13 11:51:30     1.14.2.7
-@@ -519,6 +519,7 @@
+--- a/ssl/d1_both.c
++++ b/ssl/d1_both.c
+@@ -519,6 +519,7 @@ dtls1_retrieve_buffered_fragment(SSL *s,
  
        if ( s->d1->handshake_read_seq == frag->msg_header.seq)
                {
@@ -11,7 +8,7 @@ rcsdiff -q -kk '-r1.14.2.6' '-r1.14.2.7' -u '/v/openssl/cvs/openssl/ssl/d1_both.
                pqueue_pop(s->d1->buffered_messages);
  
                al=dtls1_preprocess_fragment(s,&frag->msg_header,max);
-@@ -536,7 +537,7 @@
+@@ -536,7 +537,7 @@ dtls1_retrieve_buffered_fragment(SSL *s,
                if (al==0)
                        {
                        *ok = 1;
index a452c27..b73ed4f 100644 (file)
@@ -1,6 +1,5 @@
-diff -burN openssl-0.9.8l/Configure.rej openssl-0.9.8l.patched/Configure.rej
---- openssl-0.9.8l/Configure.rej       2009-11-05 13:07:06.000000000 +0100
-+++ openssl-0.9.8l.patched/Configure.rej       1970-01-01 01:00:00.000000000 +0100
+--- a/Configure.rej
++++ /dev/null
 @@ -1,16 +0,0 @@
 -***************
 -*** 162,167 ****