disable dropbear zlib support and split off dropbearconvert to save flash space
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2006 13:33:25 +0000 (13:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2006 13:33:25 +0000 (13:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3085 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dropbear/Config.in
package/dropbear/Makefile
package/dropbear/ipkg/dropbearconvert.control [new file with mode: 0644]
package/dropbear/patches/150-dbconvert_standalone.patch [new file with mode: 0644]

index 0c4b2f4..5ed76a5 100644 (file)
@@ -2,9 +2,13 @@ config BR2_PACKAGE_DROPBEAR
        prompt "dropbear.......................... Small SSH 2 client/server"
        tristate
        default y
-       select BR2_PACKAGE_ZLIB
        help
          A small SSH 2 server/client designed for small memory environments.
          
          http://matt.ucc.asn.au/dropbear/
 
+config BR2_PACKAGE_DBCONVERT
+       prompt "dropbearconvert................... Utility for converting SSH keys"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_DROPBEAR
index 3654887..d43e70c 100644 (file)
@@ -16,6 +16,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,DROPBEAR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,DBCONVERT,dropbearconvert,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
        $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
@@ -58,15 +59,25 @@ $(PKG_BUILD_DIR)/.configured:
                --disable-loginfunc \
                --disable-pututline \
                --disable-pututxline \
+               --disable-zlib \
        );
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LD=$(TARGET_CC) \
-               PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" \
+               PROGRAMS="dropbear dbclient dropbearkey scp" \
                MULTI=1 SCPPROGRESS=1
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               LD=$(TARGET_CC) \
+               PROGRAMS="dropbearconvert"
        touch $@
+       
+$(IPKG_DBCONVERT):
+       mkdir -p $(IDIR_DBCONVERT)/usr/bin
+       install -m 755 $(PKG_BUILD_DIR)/dropbearconvert \
+               $(IDIR_DBCONVERT)/usr/bin/dropbearconvert
+       $(IPKG_BUILD) $(IDIR_DBCONVERT) $(PACKAGE_DIR)
 
 $(IPKG_DROPBEAR):
        mkdir -p $(IDIR_DROPBEAR)/usr/bin
@@ -78,7 +89,6 @@ $(IPKG_DROPBEAR):
        ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/ssh
        ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dbclient
        ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearkey
-       ln -sf ../sbin/dropbear $(IDIR_DROPBEAR)/usr/bin/dropbearconvert
        mkdir -p $(IDIR_DROPBEAR)/etc/init.d
        install -m 755 ./files/S50dropbear $(IDIR_DROPBEAR)/etc/init.d/
        $(IPKG_BUILD) $(IDIR_DROPBEAR) $(PACKAGE_DIR)
diff --git a/package/dropbear/ipkg/dropbearconvert.control b/package/dropbear/ipkg/dropbearconvert.control
new file mode 100644 (file)
index 0000000..9dd5ecd
--- /dev/null
@@ -0,0 +1,5 @@
+Package: dropbearconvert
+Priority: optional
+Depends: zlib
+Section: net
+Description: Utility for converting SSH keys
diff --git a/package/dropbear/patches/150-dbconvert_standalone.patch b/package/dropbear/patches/150-dbconvert_standalone.patch
new file mode 100644 (file)
index 0000000..50c035a
--- /dev/null
@@ -0,0 +1,14 @@
+--- dropbear-0.47.old/options.h        2006-01-31 13:36:25.301562500 +0100
++++ dropbear-0.47.dev/options.h        2006-01-31 13:37:41.846346250 +0100
+@@ -5,6 +5,11 @@
+ #ifndef _OPTIONS_H_
+ #define _OPTIONS_H_
++#if !defined(DROPBEAR_CLIENT) && !defined(DROPBEAR_SERVER)
++#define DROPBEAR_SERVER
++#define DROPBEAR_CLIENT
++#endif
++
+ /******************************************************************
+  * Define compile-time options below - the "#ifndef DROPBEAR_XXX .... #endif"
+  * parts are to allow for commandline -DDROPBEAR_XXX options etc.