[mcs814x] add Generic and dLAN USB Extender profiles
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Sep 2012 20:25:40 +0000 (20:25 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Sep 2012 20:25:40 +0000 (20:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33313 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mcs814x/image/Makefile
target/linux/mcs814x/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk [new file with mode: 0644]

index 88c7af3..5545e04 100644 (file)
@@ -34,7 +34,7 @@ define Image/Prepare
        cp $(LINUX_DIR)/arch/$(ARCH)/boot/zImage $(KDIR)/zImage
 endef
 
-define Image/Build/dlan
+define Image/Build/Profile/dLAN_USB_Extender
        dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
        cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
        cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
@@ -46,9 +46,9 @@ define Image/BuildKernel
 endef
 
 define Image/Build
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        $(call Image/Build/$(1))
-       $(call Image/Build/dlan,$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+       $(call Image/Build/Profile/$(PROFILE),$(1))
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/mcs814x/profiles/000-Generic.mk b/target/linux/mcs814x/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..a6d0f30
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic profile
+endef
+
+define Profile/Generic/Description
+   Default profile for Moschip MCS814x targets
+endef
+$(eval $(call Profile,Generic))
+
diff --git a/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk b/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk
new file mode 100644 (file)
index 0000000..86aa5f8
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/dLAN_USB_Extender
+  NAME:=Devolo dLAN USB Extender
+  PACKAGES:=hpavcfg foot
+endef
+
+define Profile/dLAN_USB_Extender/Description
+       Package set specifically tuned for the Devolo dLAN USB Extender device.
+endef
+$(eval $(call Profile,dLAN_USB_Extender))
+