uboot-envtools: add configration for ramips devices
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Aug 2012 10:37:32 +0000 (10:37 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Aug 2012 10:37:32 +0000 (10:37 +0000)
uboot-env settings for ALL0239-3G, ALL0256N, ALL5002.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33296 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-envtools/Makefile
package/uboot-envtools/files/ramips [new file with mode: 0644]

index d8c1b20..1eebe76 100644 (file)
@@ -62,6 +62,10 @@ ifneq ($(CONFIG_TARGET_lantiq),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_ramips),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/uboot-envtools
+endif
 endef
 
 $(eval $(call BuildPackage,uboot-envtools))
diff --git a/package/uboot-envtools/files/ramips b/package/uboot-envtools/files/ramips
new file mode 100644 (file)
index 0000000..65cd49c
--- /dev/null
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/ramips.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(ramips_board_name)
+
+case "$board" in
+all0239-3g | \
+all0256n | \
+all5002)
+       ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x10000" "0x10000"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0