kernel: add ip_vti tunnel module
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Mar 2015 20:25:11 +0000 (20:25 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Mar 2015 20:25:11 +0000 (20:25 +0000)
IP VTI (Virtual Tunnel Interface) is used to create a virtual device
for IPsec VPN (similar to OpenVPN).

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44606 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index 26dd491..a5a6474 100644 (file)
@@ -405,6 +405,22 @@ endef
 $(eval $(call KernelPackage,iptunnel))
 
 
+define KernelPackage/ipvti
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=IP VTI (Virtual Tunnel Interface)
+  DEPENDS:=+kmod-iptunnel +kmod-iptunnel4 +kmod-ipsec4
+  KCONFIG:=CONFIG_NET_IPVTI
+  FILES:=$(LINUX_DIR)/net/ipv4/ip_vti.ko
+  AUTOLOAD:=$(call AutoLoad,33,ip_vti)
+endef
+
+define KernelPackage/ipvti/description
+ Kernel modules for IP VTI (Virtual Tunnel Interface)
+endef
+
+$(eval $(call KernelPackage,ipvti))
+
+
 define KernelPackage/iptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 tunneling