cope with QUILT=1 when there are no patches
authornoz <noz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Jul 2007 20:05:08 +0000 (20:05 +0000)
committernoz <noz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Jul 2007 20:05:08 +0000 (20:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8022 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index 2e7941e..fb5528e 100644 (file)
@@ -61,7 +61,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                cd $(PKG_BUILD_DIR)/patches; \
                find * -type f \! -name series | sort > series; \
        )
-       [ -f "$(PKG_BUILD_DIR)/patches/series" ] && cd $(PKG_BUILD_DIR); quilt push -a
+       -[ -s "$(PKG_BUILD_DIR)/patches/series" ] && (cd $(PKG_BUILD_DIR); quilt push -a)
        touch $@
 
 define Quilt/RefreshDir