[package] split framebuffer helper modules to their own packages
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2012 14:01:54 +0000 (14:01 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jul 2012 14:01:54 +0000 (14:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32843 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/video.mk
target/linux/ep93xx/modules.mk

index fecedb0..24fff6d 100644 (file)
@@ -12,15 +12,9 @@ VIDEO_MENU:=Video Support
 define KernelPackage/fb
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Framebuffer support
-  KCONFIG:=CONFIG_FB \
-          CONFIG_FB_CFB_FILLRECT \
-          CONFIG_FB_CFB_COPYAREA \
-          CONFIG_FB_CFB_IMAGEBLIT
-  FILES:=$(LINUX_DIR)/drivers/video/fb.ko \
-        $(LINUX_DIR)/drivers/video/cfbfillrect.ko \
-        $(LINUX_DIR)/drivers/video/cfbcopyarea.ko \
-        $(LINUX_DIR)/drivers/video/cfbimgblt.ko
-  AUTOLOAD:=$(call AutoLoad,06,fb cfbfillrect cfbcopyarea cfbimgblt)
+  KCONFIG:=CONFIG_FB
+  FILES:=$(LINUX_DIR)/drivers/video/fb.ko
+  AUTOLOAD:=$(call AutoLoad,06,fb)
 endef
 
 define KernelPackage/fb/description
@@ -29,6 +23,52 @@ endef
 
 $(eval $(call KernelPackage,fb))
 
+define KernelPackage/fb-cfb-fillrect
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software rectangle filling support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_FILLRECT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbfillrect.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
+endef
+
+define KernelPackage/fb-cfb-fillrect/description
+  Kernel support for software rectangle filling
+endef
+
+$(eval $(call KernelPackage,fb-cfb-fillrect))
+
+
+define KernelPackage/fb-cfb-copyarea
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software copy area support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_COPYAREA
+  FILES:=$(LINUX_DIR)/drivers/video/cfbcopyarea.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
+endef
+
+define KernelPackage/fb-cfb-copyarea/description
+  Kernel support for software copy area
+endef
+
+$(eval $(call KernelPackage,fb-cfb-copyarea))
+
+define KernelPackage/fb-cfb-imgblt
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software image blit support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
+endef
+
+define KernelPackage/fb-cfb-imgblt/description
+  Kernel support for software image blitting
+endef
+
+$(eval $(call KernelPackage,fb-cfb-imgblt))
+
 
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
index b8fc306..1156f61 100644 (file)
@@ -8,7 +8,8 @@
 define KernelPackage/fb-ep93xx
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=EP93xx framebuffer support
-  DEPENDS:=@TARGET_ep93xx +kmod-fb
+  DEPENDS:=@TARGET_ep93xx +kmod-fb +kmod-fb-cfb-fillrect \
+          +kmod-fb-cfb-copyarea +kmod-fb-cfb-imgblt
   KCONFIG:=CONFIG_FB_EP93XX
   FILES:=$(LINUX_DIR)/drivers/video/ep93xx-fb.ko
   AUTOLOAD:=$(call AutoLoad,51,ep93xx-fb)