Add audio feature flag.
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Feb 2010 20:03:18 +0000 (20:03 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Feb 2010 20:03:18 +0000 (20:03 +0000)
There are targets which neither have usb host nor pci support but do have audio
capabilities. Those targets should expliclitly specifiy that they support audio
through the new feature flag. The audio feature flag is also implicitly selected
by the usb and pci feature flags.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19643 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk
scripts/metadata.pl
target/Config.in
target/linux/uml/Makefile
target/linux/xburst/Makefile

index 9350dbf..53f65e5 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT||TARGET_uml
+  DEPENDS:=@AUDIO_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
index 9260a1b..c963964 100755 (executable)
@@ -152,6 +152,7 @@ sub target_config_features(@) {
 
        while ($_ = shift @_) {
                /broken/ and $ret .= "\tdepends BROKEN\n";
+               /audio/ and $ret .= "\tselect AUDIO_SUPPORT\n";
                /display/ and $ret .= "\tselect DISPLAY_SUPPORT\n";
                /gpio/ and $ret .= "\tselect GPIO_SUPPORT\n";
                /pci/ and $ret .= "\tselect PCI_SUPPORT\n";
index f5aa043..f881245 100644 (file)
@@ -11,6 +11,9 @@ config LINUX_2_6
 config HAS_FPU
        bool
 
+config AUDIO_SUPPORT
+       bool
+
 config DISPLAY_SUPPORT
        bool
 
@@ -18,6 +21,7 @@ config GPIO_SUPPORT
        bool
 
 config PCI_SUPPORT
+       select AUDIO_SUPPORT
        bool
 
 config PCIE_SUPPORT
@@ -27,6 +31,7 @@ config PCMCIA_SUPPORT
        bool
 
 config USB_SUPPORT
+       select AUDIO_SUPPORT
        bool
 
 config BIG_ENDIAN
index 5f3181f..f2d9ce4 100644 (file)
@@ -20,7 +20,7 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2
+FEATURES:=ext2 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 LINUX_VERSION:=2.6.30.10
index 7707c76..7fdb93c 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=XBurst JZ47x0
-FEATURES:=jffs2 tgz ubifs
+FEATURES:=jffs2 tgz ubifs audio
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=2.6.32.7
 
 DEVICE_TYPE=other