[ramips] fix jffs2 64k and 128k images overwrite each other
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jul 2010 11:42:17 +0000 (11:42 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jul 2010 11:42:17 +0000 (11:42 +0000)
When trying to build images with jffs2 filesystem for ramips platform
there is only one jffs2 image produced instead of two (64k and 128k).

Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22435 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index d52c41f..1addcbf 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define imgname
-$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
+$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)
 endef
 
 VMLINUX:=$(IMG_PREFIX)-vmlinux