kernel: package TI's USB 3410/505 usb driver
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Nov 2011 14:16:58 +0000 (14:16 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Nov 2011 14:16:58 +0000 (14:16 +0000)
This is a patch that adds kernel drivers for TI's USB 3410/5052
devices to the `make menuconfig` GUI during setup.

Signed-off-by: Nemanja Stefanovic <nemik@nemik.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29366 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/usb.mk

index ef05e51..834baa9 100644 (file)
@@ -354,6 +354,21 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+define KernelPackage/usb-serial-ti-usb
+  TITLE:=Support for TI USB 3410/5052
+  KCONFIG:=CONFIG_USB_SERIAL_TI
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/ti_usb_3410_5052.ko
+  AUTOLOAD:=$(call AutoLoad,65,ti_usb_3410_5052)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-ti-usb/description
+ Kernel support for TI USB 3410/5052 devices
+endef
+
+$(eval $(call KernelPackage,usb-serial-ti-usb))
+
+
 define KernelPackage/usb-serial-ipw
   TITLE:=Support for IPWireless 3G devices
   KCONFIG:=CONFIG_USB_SERIAL_IPW