uClibc: build with debug symbols by default (without changing other compile related...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Jul 2013 12:38:09 +0000 (12:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Jul 2013 12:38:09 +0000 (12:38 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37525 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/uClibc/common.mk

index dec4a1c..f0a5b3d 100644 (file)
@@ -51,7 +51,7 @@ CPU_CFLAGS = \
        -funsigned-char -fno-builtin -fno-asm \
        --std=gnu99 -ffunction-sections -fdata-sections \
        -Wno-unused-but-set-variable \
-       $(TARGET_CFLAGS)
+       $(TARGET_CFLAGS) -ggdb
 
 UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
        $(TARGET_CONFIGURE_OPTS) \