change kernel package name to kernel-VERSION-BOARD to work around ipkg bug
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Jul 2005 20:18:35 +0000 (20:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Jul 2005 20:18:35 +0000 (20:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1340 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/control/kernel.control
target/linux/linux-2.4/Makefile
target/linux/rules.mk

index 5432d21..32e6fdc 100644 (file)
@@ -1,4 +1,3 @@
-Package: kernel
 Priority: optional
 Section: sys
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
index e1ae0b3..6f08cf6 100644 (file)
@@ -40,7 +40,7 @@ IPKG_KERNEL:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(LINUX_TARGET_DIR) IPKG_CO
 PKG_BUILD_DIR := $(LINUX_BUILD_DIR)/linux-modules
 PKG_RELEASE := 1
 
-KERNEL_IPKG:=$(LINUX_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk
+KERNEL_IPKG:=$(LINUX_BUILD_DIR)/kernel-$(LINUX_VERSION)-$(BOARD)_$(PKG_RELEASE)_$(ARCH).ipk
 KERNEL_IDIR:=$(LINUX_BUILD_DIR)/kernel-ipkg
 
 include $(LINUX_KCONFIG)
@@ -197,7 +197,8 @@ $(TARGET_MODULES_DIR):
 $(KERNEL_IPKG):
        rm -rf $(KERNEL_IDIR)
        mkdir -p $(KERNEL_IDIR)/etc
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE) $(ARCH)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(PKG_RELEASE) $(ARCH)
+       echo 'Package: kernel-$(LINUX_VERSION)-$(BOARD)' >> $(KERNEL_IDIR)/CONTROL/control
        if [ -f ./config/$(BOARD).modules ]; then \
                cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
        fi
index 9446c34..75a96b4 100644 (file)
@@ -6,9 +6,9 @@ KDEPEND_$(1):=$($(4))
 endif
 
 ifeq ($$(strip $(5)),)
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE))
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE))
 else
-IDEPEND_$(1):=kernel ($(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)), $(5)
+IDEPEND_$(1):=kernel-$(LINUX_VERSION)-$(BOARD) ($(PKG_RELEASE)), $(5)
 endif
 
 PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)_$(ARCH).ipk