kernel: add a module for the isl1208 rtc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2013 15:09:43 +0000 (15:09 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2013 15:09:43 +0000 (15:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35022 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 1c8a3dc..ddaef8d 100644 (file)
@@ -539,6 +539,23 @@ endef
 $(eval $(call KernelPackage,pwm-gpio))
 
 
+define KernelPackage/rtc-isl1208
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Intersil ISL1208 RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_ISL1208
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
+endef
+
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-isl1208))
+
+
 define KernelPackage/rtc-marvell
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell SoC built-in RTC support